aboutsummaryrefslogtreecommitdiffstats
path: root/www/node4
diff options
context:
space:
mode:
Diffstat (limited to 'www/node4')
-rw-r--r--www/node4/Makefile5
-rw-r--r--www/node4/distinfo6
-rw-r--r--www/node4/files/patch-deps_v8_src_compiler_instruction.h11
-rw-r--r--www/node4/files/patch-deps_v8_src_compiler_js-type-feedback.h15
-rw-r--r--www/node4/files/patch-deps_v8_src_zone-containers.h18
5 files changed, 5 insertions, 50 deletions
diff --git a/www/node4/Makefile b/www/node4/Makefile
index 75071468686..10da09fd12e 100644
--- a/www/node4/Makefile
+++ b/www/node4/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 4.6.2
-PORTREVISION= 1
+PORTVERSION= 4.7.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -29,7 +28,7 @@ USES= compiler:c++11-lib execinfo gmake python:2 pkgconfig localbase
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFLICTS_INSTALL= node[567]-[0-9]* node01[02]-[0-9]* node-[0-9]* node-devel-[0-9]* iojs-[0-9]*
+CONFLICTS_INSTALL= node[56]-[0-9]* node01[02]-[0-9]* node-[0-9]* node-devel-[0-9]* iojs-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
diff --git a/www/node4/distinfo b/www/node4/distinfo
index 922d20c8f7e..93aeb8f08bb 100644
--- a/www/node4/distinfo
+++ b/www/node4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478724819
-SHA256 (node-v4.6.2.tar.gz) = 3c8f3af398c348cdf90fef9b983e4b46aae96a56238236542925e0bb4ee27ee8
-SIZE (node-v4.6.2.tar.gz) = 22821027
+TIMESTAMP = 1481149235
+SHA256 (node-v4.7.0.tar.gz) = 0bc45fc02e425746001a8f012d6781fa5da6e629a43654c84ab7e767368fec61
+SIZE (node-v4.7.0.tar.gz) = 22851509
diff --git a/www/node4/files/patch-deps_v8_src_compiler_instruction.h b/www/node4/files/patch-deps_v8_src_compiler_instruction.h
deleted file mode 100644
index 102a183bdf7..00000000000
--- a/www/node4/files/patch-deps_v8_src_compiler_instruction.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- deps/v8/src/compiler/instruction.h.orig 2016-04-01 00:47:45 UTC
-+++ deps/v8/src/compiler/instruction.h
-@@ -1011,7 +1011,7 @@ class InstructionBlock final : public Zo
-
- typedef ZoneDeque<Constant> ConstantDeque;
- typedef std::map<int, Constant, std::less<int>,
-- zone_allocator<std::pair<int, Constant> > > ConstantMap;
-+ zone_allocator<std::pair<const int, Constant> > > ConstantMap;
-
- typedef ZoneDeque<Instruction*> InstructionDeque;
- typedef ZoneDeque<ReferenceMap*> ReferenceMapDeque;
diff --git a/www/node4/files/patch-deps_v8_src_compiler_js-type-feedback.h b/www/node4/files/patch-deps_v8_src_compiler_js-type-feedback.h
deleted file mode 100644
index fa1314f15e5..00000000000
--- a/www/node4/files/patch-deps_v8_src_compiler_js-type-feedback.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- deps/v8/src/compiler/js-type-feedback.h.orig 2016-04-01 00:47:45 UTC
-+++ deps/v8/src/compiler/js-type-feedback.h
-@@ -33,9 +33,10 @@ class JSTypeFeedbackTable : public ZoneO
- private:
- friend class JSTypeFeedbackSpecializer;
- typedef std::map<NodeId, TypeFeedbackId, std::less<NodeId>,
-- zone_allocator<TypeFeedbackId> > TypeFeedbackIdMap;
-+ zone_allocator<std::pair<const NodeId, TypeFeedbackId> > >
-+ TypeFeedbackIdMap;
- typedef std::map<NodeId, FeedbackVectorICSlot, std::less<NodeId>,
-- zone_allocator<FeedbackVectorICSlot> >
-+ zone_allocator<std::pair<const NodeId, FeedbackVectorICSlot> > >
- FeedbackVectorICSlotMap;
-
- TypeFeedbackIdMap type_feedback_id_map_;
diff --git a/www/node4/files/patch-deps_v8_src_zone-containers.h b/www/node4/files/patch-deps_v8_src_zone-containers.h
deleted file mode 100644
index c39a5f7043f..00000000000
--- a/www/node4/files/patch-deps_v8_src_zone-containers.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- deps/v8/src/zone-containers.h.orig 2016-04-01 00:47:46 UTC
-+++ deps/v8/src/zone-containers.h
-@@ -114,12 +114,12 @@ class ZoneSet : public std::set<K, Compa
- // a zone allocator.
- template <typename K, typename V, typename Compare = std::less<K>>
- class ZoneMap
-- : public std::map<K, V, Compare, zone_allocator<std::pair<K, V>>> {
-+ : public std::map<K, V, Compare, zone_allocator<std::pair<const K, V>>> {
- public:
- // Constructs an empty map.
- explicit ZoneMap(Zone* zone)
-- : std::map<K, V, Compare, zone_allocator<std::pair<K, V>>>(
-- Compare(), zone_allocator<std::pair<K, V>>(zone)) {}
-+ : std::map<K, V, Compare, zone_allocator<std::pair<const K, V>>>(
-+ Compare(), zone_allocator<std::pair<const K, V>>(zone)) {}
- };
-
-