aboutsummaryrefslogtreecommitdiffstats
path: root/www/openvrml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/openvrml/Makefile')
-rw-r--r--www/openvrml/Makefile34
1 files changed, 27 insertions, 7 deletions
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index ec9b3965070..85202fa7ee5 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= openvrml
-PORTVERSION= 0.12.4
-PORTREVISION= 1
+PORTVERSION= 0.14.3
+PORTREVISION= 0
CATEGORIES= www graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,19 +15,29 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= VRML97 runtime and browser ("lookat")
+BUILD_DEPENDS= ${X11BASE}/lib/firefox/lib/pkgconfig/mozilla-js.pc:${PORTSDIR}/www/firefox
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png
+ png.5:${PORTSDIR}/graphics/png \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+RUN_DEPENDS= ${X11BASE}/lib/firefox/lib/pkgconfig/mozilla-js.pc:${PORTSDIR}/www/firefox
USE_REINPLACE= yes
+USE_GL= yes
USE_MESA= yes
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXext"
-CONFIGURE_ARGS= --without-spidermonkey --without-jdk --without-doxygen
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXext" \
+ PKG_CONFIG_PATH="${X11BASE}/lib/firefox/lib/pkgconfig"
+CONFIGURE_ARGS= --without-jdk
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+.if !defined(NOPORTDOCS)
+PORTDOCS= # empty, not use * 'cause args too long (for find)
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
@@ -35,6 +45,16 @@ BROKEN= "Does not compile on !i386"
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+
+post-install:
+ @${FIND} ${PREFIX}/include/openvrml -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/openvrml -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/manual/ ${DOCSDIR}
+.endif
.include <bsd.port.post.mk>