aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-POE-Component-Server-SimpleHTTP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-POE-Component-Server-SimpleHTTP/Makefile')
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/Makefile b/www/p5-POE-Component-Server-SimpleHTTP/Makefile
index 03d3f4c6d23..de344b7c295 100644
--- a/www/p5-POE-Component-Server-SimpleHTTP/Makefile
+++ b/www/p5-POE-Component-Server-SimpleHTTP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= POE-Component-Server-SimpleHTTP
-PORTVERSION= 1.58
+PORTVERSION= 2.0
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,20 +14,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Perl extension to serve HTTP requests in POE
-RUN_DEPENDS= p5-Storable>0:${PORTSDIR}/devel/p5-Storable \
- p5-libwww>0:${PORTSDIR}/www/p5-libwww \
- p5-POE>=1.0000:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= p5-Moose>=0.81:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-AttributeHelpers>0:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-MooseX-POE>=0.205:${PORTSDIR}/devel/p5-MooseX-POE \
+ p5-POE>=1.0000:${PORTSDIR}/devel/p5-POE \
+ p5-Storable>0:${PORTSDIR}/devel/p5-Storable \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= POE::Component::Server::SimpleHTTP.3 \
POE::Component::Server::SimpleHTTP::Connection.3 \
- POE::Component::Server::SimpleHTTP::PreFork.3 \
POE::Component::Server::SimpleHTTP::Response.3
OPTIONS= SSL "SSL support (POE::Component::SSLify)" on \
- PREFORK "PreFork support (IRC::Shareable)" on
.include <bsd.port.pre.mk>
@@ -35,8 +36,4 @@ OPTIONS= SSL "SSL support (POE::Component::SSLify)" on \
BUILD_DEPENDS+= p5-POE-Component-SSLify>=0.04:${PORTSDIR}/security/p5-POE-Component-SSLify
.endif
-.ifdef(WITH_PREFORK)
-BUILD_DEPENDS+= p5-IPC-Shareable>0:${PORTSDIR}/devel/p5-IPC-Shareable
-.endif
-
.include <bsd.port.post.mk>