aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WWW-FreeProxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WWW-FreeProxy/Makefile')
-rw-r--r--www/p5-WWW-FreeProxy/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/p5-WWW-FreeProxy/Makefile b/www/p5-WWW-FreeProxy/Makefile
new file mode 100644
index 00000000000..726bf799db1
--- /dev/null
+++ b/www/p5-WWW-FreeProxy/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-FreeProxy
+# Date created: 10 Oct 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-FreeProxy
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Fetch proxies from free proxy lists
+
+BUILD_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= WWW::FreeProxy.3 WWW::FreeProxy::Proxy4Free.3 WWW::FreeProxy::Samair.3 WWW::FreeProxy::Look.3 WWW::FreeProxy::PublicProxyServers.3
+
+.include <bsd.port.mk>