aboutsummaryrefslogtreecommitdiffstats
path: root/www/screem-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/screem-devel/Makefile')
-rw-r--r--www/screem-devel/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index 0a9a9975ac2..6b1f21f7cfa 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= screem
-PORTVERSION= 0.6.2
+PORTVERSION= 0.8.2
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,16 +14,26 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= coop9211@uidaho.edu
COMMENT= Nice GNOME/GTK-based HTML editor
+# www/neon needs to be updated to 0.24.3
+#LIB_DEPENDS= neon.24:${PORTSDIR}/www/neon
+
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml
+USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
+ gtksourceview
USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.ifndef WITHOUT_OPENSSL
USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-ssl
+.endif
+
USE_PERL5= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-ssl
+#CONFIGURE_ARGS+= --with-neon="${LOCALBASE}/bin"
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/editors/openoffice-devel?h=gnome-3.24&id=ce4bebc9fdf356c107303011ee9e4d9a9bdece82'>Revision bump of all ports with USE_GL after consolidation of mesa-libsrezny2017-05-231-2/+1 * devel/boost-*: update to 1.64.0jbeich2017-05-021-1/+1 * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-011-0/+1 * Upgrade to upstream svn revision r1780246. This incorporates thetruckman2017-01-318-76/+122 * editors/openoffice-devel: unbreak with clang 4.0jbeich2017-01-221-0/+39 * The output of tools like awk, date, sort, tr,... depends on the currenttijl2017-01-181-1/+1 * textproc/hunspell: update to 1.6.0jbeich2017-01-071-2/+2 * Chase update of graphics/poppler (and slaves ports) in revision r430777olivierd2017-01-071-1/+1 * devel/boost-*: update to 1.63.0jbeich2017-01-061-1/+1 * textproc/hunspell: update to 1.5.4jbeich2016-12-041-2/+2 * editors/openoffice*: unbreak consumers with hunspell 1.5jbeich2016-11-271-0/+14 * devel/boost-*: update to 1.62.0jbeich2016-11-231-1/+1 * ${RM} already has -f.mat2016-10-211-8/+8 * devel/nspr, security/nss: drop version from SONAMEjbeich2016-10-091-1/+1 * Chase update of Poppler after revision r421386olivierd2016-09-061-1/+1 * Upgrade to upstream svn revision r1753426, which includes the fix fortruckman2016-07-222-4/+4 * Add missing dependencies reported by stage-qa:truckman2016-07-121-43/+47 * Upgrade to upstream svn revision 1749607.truckman2016-06-233-17/+4 * Fix build of openoffice-4 and openoffice-devel with libc++ 3.8.0.truckman2016-05-261-0/+14 * Pet portlint - use a tab (not space) after a variable nametruckman2016-05-011-1/+1 * Revert the part of the change in r408688 that allowed the PDF Importtruckman2016-05-011-6/+4 * Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.mat2016-04-012-52/+52 * Upgrade to upstream svn revision r1735889. This contains thetruckman2016-03-213-18/+8 * Combine print/cups-base, print/cups-client and print/cups-image intotijl2016-03-111-2/+2 * Unbreak PDF Import extension when building with modern boost. Similartruckman2016-02-112-3/+17 * Disable PDF import plugin to unbreak build with modern boost.truckman2016-02-101-2/+2 * Upgrade to upstream svn revision 1727463. This fixes the upstreamtruckman2016-01-312-4/+4