aboutsummaryrefslogtreecommitdiffstats
path: root/www/wnews/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/wnews/Makefile')
-rw-r--r--www/wnews/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/www/wnews/Makefile b/www/wnews/Makefile
index 7a714e9581d..deab2e106f7 100644
--- a/www/wnews/Makefile
+++ b/www/wnews/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wnews
-PORTVERSION= 0.7
+PORTVERSION= 0.8
CATEGORIES= www
MASTER_SITES= http://samy.kerneled.org/stuff/
@@ -17,7 +17,22 @@ MAN1= wnews.1
MANCOMPRESSED= yes
PLIST_FILES= bin/wnews
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+WANT_GNOME= yes
-.include <bsd.port.mk>
+OPTIONS= GTK2 "build the GTK+ 2.0 interface" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTK2)
+CONFIGURE_ARGS+=--with-gtk2
+USE_GNOME+= gtk20
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\(GTKCFLAGS="\)|\1${PTHREAD_CFLAGS} |; \
+ s|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>