aboutsummaryrefslogtreecommitdiffstats
path: root/www/xshttpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/xshttpd/Makefile')
-rw-r--r--www/xshttpd/Makefile35
1 files changed, 30 insertions, 5 deletions
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index 28d5a2a16c8..9311852d061 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= xshttpd
-DISTVERSION= 3.3g01
-PORTREVISION= 1
-CATEGORIES= www
+DISTVERSION= 3.4g01
+CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
ftp://mud.stack.nl/pub/xs-httpd/release/
DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
@@ -22,7 +21,8 @@ CONFLICTS+= apache-[0-9]* xshttpd-devel-[0-9]*
MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
readxs.1 xsindex.1 xspasswd.1
-MAN5= httpd.conf.5 xsauth.5 xsscripts.5
+MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
+USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
GNU_CONFIGURE= yes
@@ -31,12 +31,16 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SSL "Enable https support" On \
LDAP "Enable ldap support" Off \
PCRE "Enable pcre rewriting support" Off \
+ CURL "Enable curl (proxy) support" Off \
+ M4_CONFIG "Enable m4 configuration preprocessor" Off \
PERSISTENT_PERL "Enable persistent perl interpreter" Off
+PORTDOCS= README BUGS COPYING ChangeLog
+
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
WWWDIR?= ${PREFIX}/www
PLIST_SUB= WWWDIR=${WWWDIR:S,^${PREFIX}/,,}
-CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR} --mandir=${MANPREFIX}/man
.include <bsd.port.pre.mk>
@@ -55,6 +59,12 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
CONFIGURE_ARGS+=--without-ldap
.endif
+.if defined(WITH_M4_CONFIG)
+CONFIGURE_ARGS+=--with-preprocessor
+.else
+CONFIGURE_ARGS+=--without-preprocessor
+.endif
+
.if defined(WITH_PERSISTENT_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+=--with-perl
@@ -69,6 +79,13 @@ CONFIGURE_ARGS+=--with-pcre=yes
CONFIGURE_ARGS+=--with-pcre=no
.endif
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--with-curl=yes
+.else
+CONFIGURE_ARGS+=--with-curl=no
+.endif
+
post-patch:
.for i in man/httpd.1 man/httpd.conf.5 config/httpd.conf.sample \
contrib/SSL-Makefile contrib/logrotate.sh
@@ -84,4 +101,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|mime.types ||g' \
${WRKSRC}/config/Makefile.in
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
.include <bsd.port.post.mk>