aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache22/Makefile4
-rw-r--r--www/apache22/Makefile.doc2
-rw-r--r--www/apache22/files/exp-windowsupdate.patch11
3 files changed, 0 insertions, 17 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 79d18628294..aca259c2d01 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -74,10 +74,6 @@ WITH_MPM?= prefork # or worker, perchild, threadpool, event
WITH_HTTP_PORT?= 80
-.if defined (WITH_WINDOWSUPDATEFIX)
-EXTRA_PATCHES+= ${FILESDIR}/exp-windowsupdate.patch
-.endif
-
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
.else
diff --git a/www/apache22/Makefile.doc b/www/apache22/Makefile.doc
index d5994c6e0db..923bb4048d6 100644
--- a/www/apache22/Makefile.doc
+++ b/www/apache22/Makefile.doc
@@ -69,8 +69,6 @@
## Optionnal patches:
## WITH_EXPERIMENTAL_PATCHES Add performance patches (generally backported
## from apr/httpd CVS)
-## WITH_WINDOWSUPDATEFIX Add a fix to use apache as proxy with
-## Windows Update service.
##
## Available make targets:
## show-options: prints this message
diff --git a/www/apache22/files/exp-windowsupdate.patch b/www/apache22/files/exp-windowsupdate.patch
deleted file mode 100644
index 3f130677710..00000000000
--- a/www/apache22/files/exp-windowsupdate.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- server/protocol.c.orig Tue Jun 29 08:21:28 2004
-+++ server/protocol.c Tue Jun 29 08:21:50 2004
-@@ -1248,7 +1248,7 @@
- * We can only set a C-L in the response header if we haven't already
- * sent any buckets on to the next output filter for this request.
- */
-- if (ctx->data_sent == 0 && eos) {
-+ if (ctx->data_sent == 0 && eos && !r->header_only) {
- ap_set_content_length(r, r->bytes_sent);
- }
-