aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/gdl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/gdl/Makefile')
-rw-r--r--x11-toolkits/gdl/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
new file mode 100644
index 00000000000..3012c918cbf
--- /dev/null
+++ b/x11-toolkits/gdl/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gdl
+# Date created: 24 July 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdl
+PORTVERSION= 0.1.0
+CATEGORIES?= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME}
+
+MAINTAINER?= gnome@FreeBSD.org
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>