aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/libgnomeprintui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/libgnomeprintui/Makefile')
-rw-r--r--x11-toolkits/libgnomeprintui/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-toolkits/libgnomeprintui/Makefile b/x11-toolkits/libgnomeprintui/Makefile
new file mode 100644
index 00000000000..80cedd10efb
--- /dev/null
+++ b/x11-toolkits/libgnomeprintui/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: libgnomeprintui
+# Date created: 12 April 2002
+# Whom: Maxim Sobolev <sobomax@FreBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgnomeprintui
+PORTVERSION= 1.112.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gnomeprint-2.0:${PORTSDIR}/print/libgnomeprint \
+ gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_BISON= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>