aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/wmconfig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/wmconfig/Makefile')
-rw-r--r--x11-wm/wmconfig/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/x11-wm/wmconfig/Makefile b/x11-wm/wmconfig/Makefile
index 7fd3a6eb06d..6a245663cfb 100644
--- a/x11-wm/wmconfig/Makefile
+++ b/x11-wm/wmconfig/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wmconfig
-PORTVERSION= 1.3.7
+PORTVERSION= 1.3.8
CATEGORIES= x11-wm
MASTER_SITES= http://www.arrishq.net/files/
@@ -18,8 +18,24 @@ MAN1= wmconfig.1x
PORTDOCS= AUTHORS ChangeLog COPYING README TODO
+OPTIONS_DEFINE= NLS DOCS
+OPTIONS_DEFAULT= NLS DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}