aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xfce4/Makefile')
-rw-r--r--x11-wm/xfce4/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/x11-wm/xfce4/Makefile b/x11-wm/xfce4/Makefile
index 88b9834f0ef..a676d013fc4 100644
--- a/x11-wm/xfce4/Makefile
+++ b/x11-wm/xfce4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xfce
-PORTVERSION= 3.8.8
+PORTVERSION= 3.8.8b
CATEGORIES= x11-wm
MASTER_SITES= http://www.xfce.org/archive/
@@ -26,6 +26,18 @@ CONFIGURE_ARGS= --with-conf-dir=${PREFIX}/etc/xfce \
--with-xpm=${X11BASE} \
--disable-xinerama
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_XFT) && ${WITH_XFT} == yes
+CONFIGURE_ARGS+= --enable-xft
+.else
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to enable anti-aliased font support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_XFT=yes\""
+ @${ECHO_MSG}
+.endif
+
MAN1= glob.1 xfbd.1 xfce.1 xfclock.1 xfglob.1 xfgnome.1 xfhelp.1 \
xflock.1 xfmountdev.1 xfmouse.1 xfpager.1 xfprint.1 xfrun.1 \
xfsound.1 xfterm.1 xftrash.1 xftree.1 xfwm.1
@@ -41,4 +53,4 @@ pre-patch:
pre-build:
${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}/libtool
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>