aboutsummaryrefslogtreecommitdiffstats
path: root/x11/wmbutton/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/wmbutton/Makefile')
-rw-r--r--x11/wmbutton/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/x11/wmbutton/Makefile b/x11/wmbutton/Makefile
index 7bcce6f9c4a..a29cdb1a182 100644
--- a/x11/wmbutton/Makefile
+++ b/x11/wmbutton/Makefile
@@ -9,15 +9,21 @@ PORTNAME= wmbutton
PORTVERSION= 0.6.1
PORTREVISION= 2
CATEGORIES= x11 windowmaker
-MASTER_SITES= http://greek0.net/~greek0/wmbutton/
+MASTER_SITES= http://greek0.net/wmbutton/
MAINTAINER= ports@FreeBSD.org
COMMENT= A dockapp that displays 9 buttons to run apps of your choice
+LICENSE= GPLv2
+
USE_XORG= xpm
SUB_FILES= pkg-message
+PORTDOCS= README
+PORTEXAMPLES= dot.wmbutton
+PLIST_FILES= bin/wmbutton
+
do-build:
cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} \
-I${LOCALBASE}/include/X11 -I${LOCALBASE}/include \
@@ -26,12 +32,14 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmbutton ${PREFIX}/bin/wmbutton
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/.wmbutton ${EXAMPLESDIR}/dot.wmbutton
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/.wmbutton ${EXAMPLESDIR}/dot.wmbutton
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>