aboutsummaryrefslogtreecommitdiffstats
path: root/packages/contracts/package.json
diff options
context:
space:
mode:
Diffstat (limited to 'packages/contracts/package.json')
-rw-r--r--packages/contracts/package.json28
1 files changed, 14 insertions, 14 deletions
diff --git a/packages/contracts/package.json b/packages/contracts/package.json
index 067a20775..799f72d9e 100644
--- a/packages/contracts/package.json
+++ b/packages/contracts/package.json
@@ -1,7 +1,7 @@
{
"private": true,
"name": "contracts",
- "version": "2.1.39",
+ "version": "2.1.40",
"engines": {
"node": ">=6.12"
},
@@ -46,11 +46,11 @@
},
"homepage": "https://github.com/0xProject/0x-monorepo/packages/contracts/README.md",
"devDependencies": {
- "@0xproject/abi-gen": "^1.0.4",
- "@0xproject/dev-utils": "^1.0.3",
- "@0xproject/sol-cov": "^1.0.3",
- "@0xproject/subproviders": "^1.0.4",
- "@0xproject/tslint-config": "^1.0.4",
+ "@0xproject/abi-gen": "^1.0.5",
+ "@0xproject/dev-utils": "^1.0.4",
+ "@0xproject/sol-cov": "^2.0.0",
+ "@0xproject/subproviders": "^1.0.5",
+ "@0xproject/tslint-config": "^1.0.5",
"@types/bn.js": "^4.11.0",
"@types/ethereumjs-abi": "^0.6.0",
"@types/lodash": "4.14.104",
@@ -72,16 +72,16 @@
"yargs": "^10.0.3"
},
"dependencies": {
- "@0xproject/base-contract": "^1.0.4",
- "@0xproject/order-utils": "^1.0.1-rc.2",
- "@0xproject/sol-compiler": "^1.0.4",
- "@0xproject/types": "^1.0.1-rc.3",
- "@0xproject/typescript-typings": "^1.0.3",
- "@0xproject/utils": "^1.0.4",
- "@0xproject/web3-wrapper": "^1.1.2",
+ "@0xproject/base-contract": "^2.0.0-rc.1",
+ "@0xproject/order-utils": "^1.0.1-rc.3",
+ "@0xproject/sol-compiler": "^1.0.5",
+ "@0xproject/types": "^1.0.1-rc.4",
+ "@0xproject/typescript-typings": "^1.0.4",
+ "@0xproject/utils": "^1.0.5",
+ "@0xproject/web3-wrapper": "^1.2.0",
"@types/js-combinatorics": "^0.5.29",
"bn.js": "^4.11.8",
- "ethereum-types": "^1.0.3",
+ "ethereum-types": "^1.0.4",
"ethereumjs-abi": "0.6.5",
"ethereumjs-util": "^5.1.1",
"ethers": "3.0.22",
d> * ftp/wget: fix build with texinfo-5 installedvd2013-05-171-0/+40 * - Update to 0.9.10bdrewery2013-05-174-35/+49 * ftp/wget: Add an option for choosing whether to use PCRE or not.vd2013-05-141-12/+13 * ftp/wget: hook a dependency to devel/pcrevd2013-05-131-0/+11 * mark as BROKENoliver2013-05-131-0/+2 * Merge r317659 by ale from ftp/php5-ftp:flo2013-05-101-5/+4 * - Remove leading indefinite article from COMMENTsunpoet2013-05-081-8/+3 * Make ssl support deterministic.ale2013-05-081-0/+4 * - Update to 20130505bdrewery2013-05-072-11/+6 * - Use CERTFILE for custom certificate locationsunpoet2013-05-071-4/+3 * - Fix shebang line for users without USE_PERL=yessunpoet2013-05-071-2/+1 * Convert USE_NCURSES by USES=ncursesbapt2013-05-064-6/+5 * Fix installation of ports that rely on cp -n for installing files. r245960flo2013-05-051-3/+3 * Chase security/libgcrypt updateehaupt2013-05-041-0/+1 * Update to version 4.0.demon2013-04-303-8/+9 * - Update to 0.8.3miwi2013-04-307-116/+167 * - Update to 1.42miwi2013-04-303-37/+33 * Add Gstreamer 1.0.7. This is the new stable version of thekwm2013-04-282-0/+14 * - Update to 0.42culot2013-04-282-3/+3 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-276-8/+6 * Convert from USE_GETTEXT to USES= gettextbapt2013-04-272-19/+13 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-263-4/+3 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-259-9/+9 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-241-2/+1 * Convert to USES=gettextehaupt2013-04-231-1/+1 * Convert f* to USES=pkgconfigbapt2013-04-232-7/+3 * Fix NLS supportpawel2013-04-201-2/+1 * ftp/wget:vd2013-04-182-11/+1 * ftp/wget:vd2013-04-111-2/+2 * - Fix build on amd64ehaupt2013-04-024-9/+26 * - Mark BROKEN fails to buildmiwi2013-04-021-0/+1 * For perl@ owned ports:eadler2013-03-292-2/+2 * Style: tab -> space.eadler2013-03-291-1/+1 * - Update to 20130325miwi2013-03-289-25/+19 * Convert left unconverted ports in ftp to new options frameworkbapt2013-03-267-141/+102 * - Fix build after glib update [1]pawel2013-03-251-5/+9 * - Update to 2.6.2acm2013-03-231-1/+1 * - convert USE_CMAKE to USESmakc2013-03-231-1/+1 * This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.eadler2013-03-192-2/+2 * Fix a long standing bug of lib/charset.alias being overwritten, modified, and...bapt2013-03-181-5/+2 * Update to 4.4.5martymac2013-03-182-3/+3 * Update to version 3.7.2.demon2013-03-182-3/+3 * Correct PORTREVISIONmiwi2013-03-181-1/+1 * - Unbreak buildmiwi2013-03-181-4/+2 * In categories starting with [efg], remove empty lines from pkg-plist (exceptdanfe2013-03-171-1/+0 * - Convert to PEAR_AUTOINSTALLmiwi2013-03-151-14/+2 * - adopt optionsNG and trim historical headersjgh2013-03-141-6/+4 * 2013-03-05 ftp/proma: Broken for more than 6 monthbapt2013-03-106-98/+0 * Fix build with disabled IPv6mm2013-03-092-0/+13 * Remove indefinite article from COMMENTehaupt2013-03-081-1/+1 * - Update to 1.95-4.1tota2013-03-082-4/+3 * Update proftpd to 1.3.4cmm2013-03-073-4/+4 * update math/R to 2.15.3, and adjust dependent portsbf2013-03-071-1/+1 * - Please welcome back Chris Petrik as maintainer ofbdrewery2013-03-074-20/+7 * Update to 4.4.4martymac2013-03-052-3/+3 * Update to 3.6.0.2.jsa2013-03-042-8/+4 * Deorbit expired ftp/ftp-tls and ftp/ftpd-tls.marius2013-03-0318-561/+0 * Convert to new options frameworkbapt2013-02-211-11/+8 * - Reassign ports from avl@ back to pool at his request.fluffy2013-02-211-1/+1 * Upgrade ftp/wget from 1.13.4 to 1.14vd2013-02-192-4/+3 * Horde suite update:mm2013-02-132-3/+3 * Update to 4.4.3martymac2013-02-122-4/+3 * - Support CFLAGS/CXXFLAGS properlymiwi2013-02-081-22/+23 * - Fix breakage in the DYNAMIC-enabled ports triggered by the recentpgj2013-02-061-0/+1 * - Add UPDATING entry for gnutls updatenovel2013-02-066-6/+8 * Mark as deprecated a bunch of ports that are marked as broken for more than 6bapt2013-02-051-0/+2 * - Update to 4.4.2martymac2013-02-043-3/+149 * - Fix all cases of 'No newline at end of file' in ports treeak2013-02-011-1/+1 * Update to 4.4.1martymac2013-02-013-8/+5 * Bump PORTREVISION after DESKTOP_ENTRIES updatemakc2013-01-231-1/+1 * - Update DESKTOP_ENTRIES:makc2013-01-231-4/+4 * Only install the bash completion file if the newly-added BASH option is set.rakuco2013-01-201-5/+11 * - Update to 1.2.4.rakuco2013-01-172-8/+4 * - Use DOC instead of NOPORTDOCSehaupt2013-01-151-6/+6 * Update to 0.38.tobez2013-01-132-8/+4 * Update Horde Groupware to 5.0.3:mm2013-01-112-3/+3 * update the R base ports to 2.15.2 and adjust dependent portsbf2013-01-051-0/+1 * Update to 1.125.tobez2013-01-012-13/+7 * Mark deprecated with an expiration on 2013-01-31. Unfortunately, thesemarius2012-12-302-0/+6 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-304-0/+12 * - Convert to new options frameworkbapt2012-12-301-42/+42 * - Update The Glorious Glasgow Haskell Compiler to version 7.4.2pgj2012-12-203-12/+5 * Horde port fixes:mm2012-12-181-2/+2 * Rename horde4-* apps to horde-*mm2012-12-184-1/+1 * Cleanup supporting perl version 5.8 and 5.10,az2012-12-172-18/+2 * Rename package names for horde3 ports to horde3-*mm2012-12-161-1/+1 * - Support USE_READLINE.araujo2012-12-141-10/+14 * - Support USE_READLINE.araujo2012-12-141-15/+33 * - Support USE_READLINE.araujo2012-12-141-10/+16 * Update horde4 packages and applications to horde5mm2012-12-122-8/+10 * Rename old horde applications to horde3- prefixmm2012-12-126-2/+2 * - Use radio options for SSL flavourmartymac2012-12-121-6/+6 * Use current local time Perl module, timelocal.pl is deprecated.cy2012-12-112-1/+13 * Convert SINGLE -> RADIO optionbapt2012-12-111-5/+4 * Update PCRE to 8.32mm2012-12-111-1/+1 * Decommissioning java 1.5 (EOLed since October 2009):bapt2012-12-101-6/+2 * - update to 3.0.2dinoex2012-12-103-14/+10 * Revert Chris Petrik's ports to the pool. Thank you for all your work so far,...eadler2012-12-103-3/+3 * - Reset MAINTAINER on ports with addresses that have unrecoverable bounces.zi2012-12-071-1/+1 * 2012-11-26 ftp/mget: No more public distfilesbapt2012-11-284-41/+0 * - Update to 1.2.3bdrewery2012-11-282-4/+8 * Updted FileZilla to 3.6.0.1 and convert to OptionsNG format.jsa2012-11-27