aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarek Kotewicz <marek.kotewicz@gmail.com>2014-12-10 18:39:41 +0800
committerMarek Kotewicz <marek.kotewicz@gmail.com>2014-12-10 18:39:41 +0800
commit37f7535a00697b2ad971b3e53c6dc941a64384d1 (patch)
treee8fc50145fc4518997ff9dbfc18c07cb03cdc3a1 /CMakeLists.txt
parentbc616ecea98cef988ab3c3c6d9b21eb78dab78da (diff)
downloaddexon-solidity-37f7535a00697b2ad971b3e53c6dc941a64384d1.tar.gz
dexon-solidity-37f7535a00697b2ad971b3e53c6dc941a64384d1.tar.zst
dexon-solidity-37f7535a00697b2ad971b3e53c6dc941a64384d1.zip
jsonrpc option in cmakes, removed all warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 895b22ae..ad93609f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,10 @@
cmake_policy(SET CMP0015 NEW)
+# this policy was introduced in cmake 3.0
+# remove if, once 3.0 will be used on unix
+if (APPLE)
+ # old policy do not use MACOSX_RPATH
+ cmake_policy(SET CMP0042 OLD)
+endif()
set(CMAKE_AUTOMOC OFF)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSTATICLIB")