aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLefteris Karapetsas <lefteris@refu.co>2014-12-02 00:03:04 +0800
committerLefteris Karapetsas <lefteris@refu.co>2014-12-02 00:03:04 +0800
commit43d6726dd78e35bf79fa2da3824c2916c5e6b0a8 (patch)
tree13299ee2623a590ace54c3554156033dffa98779 /CMakeLists.txt
parent3fc2708d657525162567b663a07cf8cb5b1c59aa (diff)
downloaddexon-solidity-43d6726dd78e35bf79fa2da3824c2916c5e6b0a8.tar.gz
dexon-solidity-43d6726dd78e35bf79fa2da3824c2916c5e6b0a8.tar.zst
dexon-solidity-43d6726dd78e35bf79fa2da3824c2916c5e6b0a8.zip
Exporting Natspec documentation to a JSON interface
- Adding a getDocumentation() function to solidity compiler stack so that we can obtain the natspec interface for a contract - Adding libjsoncpp as a dependency of libsolidity. This is done in a dirty way, using libjsonrpc-cpp s an intermediate dependency for the moment. Will fix soon. - Start of a test file for Natspec exporting to JSON
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea2ef4b7..b5147ced 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,10 @@ endif()
include_directories(..)
target_link_libraries(${EXECUTABLE} evmcore devcore)
+# TODO: Temporary until PR 532 https://github.com/ethereum/cpp-ethereum/pull/532
+# gets accepted. Then we can simply add jsoncpp as a dependency and not the
+# whole of JSONRPC as we are doing right here
+target_link_libraries(${EXECUTABLE} ${JSONRPC_LS})
install( TARGETS ${EXECUTABLE} ARCHIVE DESTINATION lib LIBRARY DESTINATION lib )
install( FILES ${HEADERS} DESTINATION include/${EXECUTABLE} )