aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-09-18 23:33:32 +0800
committerPaweł Bylica <chfast@gmail.com>2017-09-19 17:55:55 +0800
commit5706508332f9caffa077c0c313b82f538a13c5c7 (patch)
treec71edd15352325c2d346921745b549454b454170 /CMakeLists.txt
parentc289fd3d9eded048f229add7f6c7f1cfd201b32d (diff)
downloaddexon-solidity-5706508332f9caffa077c0c313b82f538a13c5c7.tar.gz
dexon-solidity-5706508332f9caffa077c0c313b82f538a13c5c7.tar.zst
dexon-solidity-5706508332f9caffa077c0c313b82f538a13c5c7.zip
deps: Move and fix jsoncpp.cmake from deps submodule
This copies jsoncpp.cmake from ethereum/cpp-dependencies repo and adds BUILD_BYPRODUCT information to ExternalProject configuration (required by Ninja).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a65071d..89d627dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ option(SOLC_LINK_STATIC "Link solc executable statically on supported platforms"
# Let's find our dependencies
include(EthDependencies)
-include(deps/jsoncpp.cmake)
+include(jsoncpp)
find_package(Threads)