aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <chris@ethereum.org>2018-12-20 18:56:55 +0800
committerGitHub <noreply@github.com>2018-12-20 18:56:55 +0800
commit8825533222519c051693d1fb4bcaba6ea0cde032 (patch)
treea57e3ced5af0c81f77d8c7edf7eeb932ea0e7c61 /CMakeLists.txt
parent8d9186b78558197e614c1b1441a0fc94233e3e77 (diff)
parent639622c6d7b3c449252962cc16cf5274e4fcbafc (diff)
downloaddexon-solidity-8825533222519c051693d1fb4bcaba6ea0cde032.tar.gz
dexon-solidity-8825533222519c051693d1fb4bcaba6ea0cde032.tar.zst
dexon-solidity-8825533222519c051693d1fb4bcaba6ea0cde032.zip
Merge pull request #5699 from ethereum/cmake-no-c-dependency
cmake: Do not depend on a C compiler to be present
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bceb514..1db1d052 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ eth_policy()
# project name and version should be set after cmake_policy CMP0048
set(PROJECT_VERSION "0.5.3")
-project(solidity VERSION ${PROJECT_VERSION})
+project(solidity VERSION ${PROJECT_VERSION} LANGUAGES CXX)
option(LLL "Build LLL" OFF)
option(SOLC_LINK_STATIC "Link solc executable statically on supported platforms" OFF)