aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLefteris Karapetsas <lefteris@refu.co>2015-09-11 19:43:58 +0800
committerLefteris Karapetsas <lefteris@refu.co>2015-09-11 19:43:58 +0800
commit9c3d0c4d8162c42723337d0f26c8d98198c2cac0 (patch)
tree718ee5d9bd6bb9a4a8b89f2bd825a0c37426be7d /CMakeLists.txt
parent8355c0ad404fbbe3d21b4bd2b062a9881c08162a (diff)
downloaddexon-solidity-9c3d0c4d8162c42723337d0f26c8d98198c2cac0.tar.gz
dexon-solidity-9c3d0c4d8162c42723337d0f26c8d98198c2cac0.tar.zst
dexon-solidity-9c3d0c4d8162c42723337d0f26c8d98198c2cac0.zip
Add cmake defaults for split repo builds.
Basically same problem as the one seen in [this](https://github.com/ethereum/webthree/pull/34) PR.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1dcacaf..69cbe0cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,10 @@ include(EthExecutableHelper)
# Include utils
include(EthUtils)
+include(EthOptions)
+configure_project()
+print_config()
+
add_subdirectory(libsolidity)
add_subdirectory(solc)
add_subdirectory(test)