aboutsummaryrefslogtreecommitdiffstats
path: root/libdevcore/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Arlt <alexander.arlt@arlt-labs.com>2018-02-07 09:05:20 +0800
committerAlex Beregszaszi <alex@rtfs.hu>2018-02-21 04:58:26 +0800
commit0f29ac4e563f60be781b31ed9ef2693e1a19dcc8 (patch)
tree888d535ad5698b41f6979622040c3dcce3d300ca /libdevcore/CMakeLists.txt
parentdcc4083b231e3574a64b5b2a329a7401677610da (diff)
downloaddexon-solidity-0f29ac4e563f60be781b31ed9ef2693e1a19dcc8.tar.gz
dexon-solidity-0f29ac4e563f60be781b31ed9ef2693e1a19dcc8.tar.zst
dexon-solidity-0f29ac4e563f60be781b31ed9ef2693e1a19dcc8.zip
Add new JSON API for better abstraction and for supporting strict JSON parsing
Diffstat (limited to 'libdevcore/CMakeLists.txt')
-rw-r--r--libdevcore/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/libdevcore/CMakeLists.txt b/libdevcore/CMakeLists.txt
index a1c4c2d3..d107f701 100644
--- a/libdevcore/CMakeLists.txt
+++ b/libdevcore/CMakeLists.txt
@@ -2,7 +2,9 @@ file(GLOB sources "*.cpp")
file(GLOB headers "*.h")
add_library(devcore ${sources} ${headers})
-target_link_libraries(devcore PRIVATE ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(devcore PRIVATE ${JSONCPP_LIBRARY} ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
target_include_directories(devcore SYSTEM PUBLIC ${Boost_INCLUDE_DIRS})
target_include_directories(devcore PUBLIC "${CMAKE_SOURCE_DIR}")
+target_include_directories(devcore PUBLIC "${JSONCPP_INCLUDE_DIR}")
+add_dependencies(devcore jsoncpp)
add_dependencies(devcore solidity_BuildInfo.h)