aboutsummaryrefslogtreecommitdiffstats
path: root/libdevcore/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-08-22 22:37:27 +0800
committerPaweł Bylica <chfast@gmail.com>2017-08-22 22:45:57 +0800
commit15fd43f0357e1f3c6ec1262df6ee39b06a6fe3f9 (patch)
treeb5b353813d9b0f97dcb67e089db1da87357259a1 /libdevcore/CMakeLists.txt
parent0dc73913e1b72e89ffdbf05592798d4bbfbf1714 (diff)
downloaddexon-solidity-15fd43f0357e1f3c6ec1262df6ee39b06a6fe3f9.tar.gz
dexon-solidity-15fd43f0357e1f3c6ec1262df6ee39b06a6fe3f9.tar.zst
dexon-solidity-15fd43f0357e1f3c6ec1262df6ee39b06a6fe3f9.zip
CMake: Fix linking with pthread
Diffstat (limited to 'libdevcore/CMakeLists.txt')
-rw-r--r--libdevcore/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libdevcore/CMakeLists.txt b/libdevcore/CMakeLists.txt
index 4b15427f..016d7ea3 100644
--- a/libdevcore/CMakeLists.txt
+++ b/libdevcore/CMakeLists.txt
@@ -2,7 +2,7 @@ file(GLOB sources "*.cpp")
file(GLOB headers "*.h")
add_library(devcore ${sources} ${headers})
-target_link_libraries(devcore PRIVATE ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES})
+target_link_libraries(devcore PRIVATE ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} Threads::Threads)
target_include_directories(devcore SYSTEM PUBLIC ${Boost_INCLUDE_DIRS})
target_include_directories(devcore PRIVATE ..)
add_dependencies(devcore solidity_BuildInfo.h)