aboutsummaryrefslogtreecommitdiffstats
path: root/libdevcore/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Kirchner <daniel@ekpyron.org>2018-12-17 20:42:48 +0800
committerDaniel Kirchner <daniel@ekpyron.org>2018-12-17 22:15:11 +0800
commit2f698b6efe1b1bb932b238a5dd912b290978ac72 (patch)
treee5c669583348c70c91eceb4655701e3cf9809ef5 /libdevcore/CMakeLists.txt
parent8d3617b7c522d74bcc36a1fbc1eb7c16bf96ad4d (diff)
downloaddexon-solidity-2f698b6efe1b1bb932b238a5dd912b290978ac72.tar.gz
dexon-solidity-2f698b6efe1b1bb932b238a5dd912b290978ac72.tar.zst
dexon-solidity-2f698b6efe1b1bb932b238a5dd912b290978ac72.zip
Use imported CMake targets.
Diffstat (limited to 'libdevcore/CMakeLists.txt')
-rw-r--r--libdevcore/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libdevcore/CMakeLists.txt b/libdevcore/CMakeLists.txt
index 01a8bcc6..e3ebc20b 100644
--- a/libdevcore/CMakeLists.txt
+++ b/libdevcore/CMakeLists.txt
@@ -12,7 +12,7 @@ set(sources
)
add_library(devcore ${sources})
-target_link_libraries(devcore PRIVATE jsoncpp ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(devcore PUBLIC jsoncpp ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} Threads::Threads)
target_include_directories(devcore PUBLIC "${CMAKE_SOURCE_DIR}")
target_include_directories(devcore SYSTEM PUBLIC ${Boost_INCLUDE_DIRS})
add_dependencies(devcore solidity_BuildInfo.h)