aboutsummaryrefslogtreecommitdiffstats
path: root/libdevcore/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Parpart <christian@ethereum.org>2018-11-23 21:21:17 +0800
committerChristian Parpart <christian@ethereum.org>2018-11-26 21:39:24 +0800
commitcdd8c72c9d38a6638cd23db58079251b6a632e3b (patch)
tree62396cc259a8e34296963df6c6b20474a752b51b /libdevcore/CMakeLists.txt
parent96333f303373e073ef58a676983ed368fcd4b9f4 (diff)
downloaddexon-solidity-cdd8c72c9d38a6638cd23db58079251b6a632e3b.tar.gz
dexon-solidity-cdd8c72c9d38a6638cd23db58079251b6a632e3b.tar.zst
dexon-solidity-cdd8c72c9d38a6638cd23db58079251b6a632e3b.zip
CMake: Explicitly state which files to compile instead of relying on globbing.
Also remove header file lists, as there is no need to add them to add_library() or add_executable(), which should lower maintenance of the cmake files.
Diffstat (limited to 'libdevcore/CMakeLists.txt')
-rw-r--r--libdevcore/CMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/libdevcore/CMakeLists.txt b/libdevcore/CMakeLists.txt
index fa7e3f48..01a8bcc6 100644
--- a/libdevcore/CMakeLists.txt
+++ b/libdevcore/CMakeLists.txt
@@ -1,7 +1,17 @@
-file(GLOB sources "*.cpp")
-file(GLOB headers "*.h")
+set(sources
+ CommonData.cpp
+ CommonIO.cpp
+ Exceptions.cpp
+ IndentedWriter.cpp
+ JSON.cpp
+ Keccak256.cpp
+ StringUtils.cpp
+ SwarmHash.cpp
+ UTF8.cpp
+ Whiskers.cpp
+)
-add_library(devcore ${sources} ${headers})
+add_library(devcore ${sources})
target_link_libraries(devcore PRIVATE jsoncpp ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
target_include_directories(devcore PUBLIC "${CMAKE_SOURCE_DIR}")
target_include_directories(devcore SYSTEM PUBLIC ${Boost_INCLUDE_DIRS})