aboutsummaryrefslogtreecommitdiffstats
path: root/libdevcore/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-08-23 23:54:53 +0800
committerPaweł Bylica <chfast@gmail.com>2017-08-23 23:54:53 +0800
commitee09a0664780a6ffd5affa27b7dcb7fc2deef608 (patch)
tree8feda4b4734d3e27ba8666a326ed4c501bda7f31 /libdevcore/CMakeLists.txt
parent3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905 (diff)
downloaddexon-solidity-ee09a0664780a6ffd5affa27b7dcb7fc2deef608.tar.gz
dexon-solidity-ee09a0664780a6ffd5affa27b7dcb7fc2deef608.tar.zst
dexon-solidity-ee09a0664780a6ffd5affa27b7dcb7fc2deef608.zip
CMake: Add back compatibility with CMake 3.0
Diffstat (limited to 'libdevcore/CMakeLists.txt')
-rw-r--r--libdevcore/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libdevcore/CMakeLists.txt b/libdevcore/CMakeLists.txt
index b97866f4..a1c4c2d3 100644
--- a/libdevcore/CMakeLists.txt
+++ b/libdevcore/CMakeLists.txt
@@ -2,7 +2,7 @@ file(GLOB sources "*.cpp")
file(GLOB headers "*.h")
add_library(devcore ${sources} ${headers})
-target_link_libraries(devcore PRIVATE ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} Threads::Threads)
+target_link_libraries(devcore PRIVATE ${Boost_FILESYSTEM_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${Boost_SYSTEM_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
target_include_directories(devcore SYSTEM PUBLIC ${Boost_INCLUDE_DIRS})
target_include_directories(devcore PUBLIC "${CMAKE_SOURCE_DIR}")
add_dependencies(devcore solidity_BuildInfo.h)