aboutsummaryrefslogtreecommitdiffstats
path: root/libsolidity/CMakeLists.txt
diff options
context:
space:
mode:
authorMatías Aereal Aeón <aereal@gmail.com>2018-08-08 22:46:17 +0800
committerMatías Aereal Aeón <aereal@gmail.com>2018-08-08 23:43:57 +0800
commit4b20708c497cfbbb8a489339b91e26f05d0bd7a2 (patch)
tree1dbf784d05992de48d9d094258debc855d267fef /libsolidity/CMakeLists.txt
parent009a55c82d22f08fd207739d7b8aeff215fb7c03 (diff)
downloaddexon-solidity-4b20708c497cfbbb8a489339b91e26f05d0bd7a2.tar.gz
dexon-solidity-4b20708c497cfbbb8a489339b91e26f05d0bd7a2.tar.zst
dexon-solidity-4b20708c497cfbbb8a489339b91e26f05d0bd7a2.zip
cmake flags to make solvers optional. Implementation of #4651
Diffstat (limited to 'libsolidity/CMakeLists.txt')
-rw-r--r--libsolidity/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libsolidity/CMakeLists.txt b/libsolidity/CMakeLists.txt
index 706b3b08..49095fff 100644
--- a/libsolidity/CMakeLists.txt
+++ b/libsolidity/CMakeLists.txt
@@ -27,7 +27,8 @@ else()
endif()
if (NOT (${Z3_FOUND} OR ${CVC4_FOUND}))
- message("No SMT solver found. Optional SMT checking will not be available. Please install Z3 or CVC4 if it is desired.")
+ message("No SMT solver found (or it has been forcefully disabled). Optional SMT checking will not be available.\
+ \nPlease install Z3 or CVC4 or remove the option disabling them (USE_Z3, USE_CVC4).")
endif()
add_library(solidity ${sources} ${headers})