aboutsummaryrefslogtreecommitdiffstats
path: root/libsolidity/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Kirchner <daniel@ekpyron.org>2018-08-08 23:23:15 +0800
committerDaniel Kirchner <daniel@ekpyron.org>2018-08-09 01:02:59 +0800
commitc7a0f441591de8b3ee0adc09c70146319e79dc93 (patch)
treeeb8ce4f0462486aa5c4ed687ff21e3111e2660f1 /libsolidity/CMakeLists.txt
parent9b4546c487bc59e790716a11531e660110ca81e9 (diff)
downloaddexon-solidity-c7a0f441591de8b3ee0adc09c70146319e79dc93.tar.gz
dexon-solidity-c7a0f441591de8b3ee0adc09c70146319e79dc93.tar.zst
dexon-solidity-c7a0f441591de8b3ee0adc09c70146319e79dc93.zip
Do not force GMP to be present as dependency of CVC4, but also allow CLN instead.
Diffstat (limited to 'libsolidity/CMakeLists.txt')
-rw-r--r--libsolidity/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/libsolidity/CMakeLists.txt b/libsolidity/CMakeLists.txt
index 872504f3..91a4678a 100644
--- a/libsolidity/CMakeLists.txt
+++ b/libsolidity/CMakeLists.txt
@@ -11,17 +11,11 @@ else()
list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/formal/Z3Interface.cpp")
endif()
-find_package(GMP QUIET)
find_package(CVC4 QUIET)
if (${CVC4_FOUND})
- if (${GMP_FOUND})
- include_directories(${CVC4_INCLUDE_DIR})
- add_definitions(-DHAVE_CVC4)
- message("CVC4 SMT solver and GMP found. This enables optional SMT checking with CVC4.")
- else()
- message("CVC4 SMT solver found but its dependency GMP was NOT found. Optional SMT checking with CVC4 will not be available. Please install GMP if it is desired.")
- list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/formal/CVC4Interface.cpp")
- endif()
+ include_directories(${CVC4_INCLUDE_DIR})
+ add_definitions(-DHAVE_CVC4)
+ message("CVC4 SMT solver found. This enables optional SMT checking with CVC4.")
else()
list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/formal/CVC4Interface.cpp")
endif()
@@ -38,7 +32,6 @@ if (${Z3_FOUND})
target_link_libraries(solidity PUBLIC ${Z3_LIBRARY})
endif()
-if (${CVC4_FOUND} AND ${GMP_FOUND})
+if (${CVC4_FOUND})
target_link_libraries(solidity PUBLIC ${CVC4_LIBRARIES})
- target_link_libraries(solidity PUBLIC ${GMP_LIBRARY})
endif()