aboutsummaryrefslogtreecommitdiffstats
path: root/lllc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Beregszaszi <alex@rtfs.hu>2017-08-23 19:36:24 +0800
committerGitHub <noreply@github.com>2017-08-23 19:36:24 +0800
commit3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905 (patch)
tree3af9644b27a6fd453610d26ffe65bf4ca98d9aa9 /lllc/CMakeLists.txt
parentc5f11d938f6670d9dbe0d7212097089c757fd91a (diff)
parent09628dee8c86e71119884204eb729fe439fb3bad (diff)
downloaddexon-solidity-3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905.tar.gz
dexon-solidity-3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905.tar.zst
dexon-solidity-3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905.zip
Merge pull request #2757 from ethereum/cmake
Static linking
Diffstat (limited to 'lllc/CMakeLists.txt')
-rw-r--r--lllc/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/lllc/CMakeLists.txt b/lllc/CMakeLists.txt
index 3bd11187..7bebd0b1 100644
--- a/lllc/CMakeLists.txt
+++ b/lllc/CMakeLists.txt
@@ -1,12 +1,3 @@
-aux_source_directory(. SRC_LIST)
-
-set(EXECUTABLE lllc)
-
-file(GLOB HEADERS "*.h")
-include_directories(BEFORE ..)
-eth_simple_add_executable(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
-
-eth_use(${EXECUTABLE} REQUIRED Solidity::lll Dev::buildinfo Solidity::solevmasm)
-
-install( TARGETS ${EXECUTABLE} DESTINATION bin )
+add_executable(lllc main.cpp)
+target_link_libraries(lllc PRIVATE lll)