aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <c@ethdev.com>2016-07-01 16:20:13 +0800
committerchriseth <c@ethdev.com>2016-07-01 16:20:13 +0800
commita15b533323ffeb2e4ef4875367b3ef2877f8b786 (patch)
treec7eac99e657d71851186c75a1bc15abf49f25681 /test/CMakeLists.txt
parent9216a4d99113ad9e9edac3aa97690aa7015ffca1 (diff)
downloaddexon-solidity-a15b533323ffeb2e4ef4875367b3ef2877f8b786.tar.gz
dexon-solidity-a15b533323ffeb2e4ef4875367b3ef2877f8b786.tar.zst
dexon-solidity-a15b533323ffeb2e4ef4875367b3ef2877f8b786.zip
Do not link to libethereum for tests.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 794b6e4d..efcbb82e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -26,7 +26,7 @@ file(GLOB HEADERS "*.h" "*/*.h")
set(EXECUTABLE soltest)
eth_simple_add_executable(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
-eth_use(${EXECUTABLE} REQUIRED Solidity::solidity Eth::ethereum Eth::ethcore)
+eth_use(${EXECUTABLE} REQUIRED Solidity::solidity Eth::ethcore)
include_directories(BEFORE ..)
target_link_libraries(${EXECUTABLE} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})