aboutsummaryrefslogtreecommitdiffstats
path: root/libevmasm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libevmasm/CMakeLists.txt')
-rw-r--r--libevmasm/CMakeLists.txt16
1 files changed, 5 insertions, 11 deletions
diff --git a/libevmasm/CMakeLists.txt b/libevmasm/CMakeLists.txt
index 9c7efb86..914339e7 100644
--- a/libevmasm/CMakeLists.txt
+++ b/libevmasm/CMakeLists.txt
@@ -1,12 +1,6 @@
-aux_source_directory(. SRC_LIST)
+file(GLOB sources "*.cpp")
+file(GLOB headers "*.h")
-set(EXECUTABLE solevmasm)
-
-file(GLOB HEADERS "*.h")
-
-include_directories(BEFORE ..)
-add_library(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
-eth_use(${EXECUTABLE} REQUIRED Dev::soldevcore)
-target_link_libraries(${EXECUTABLE} jsoncpp)
-
-install( TARGETS ${EXECUTABLE} RUNTIME DESTINATION bin ARCHIVE DESTINATION lib LIBRARY DESTINATION lib )
+add_library(evmasm ${sources} ${headers})
+target_link_libraries(evmasm PUBLIC devcore jsoncpp)
+target_include_directories(evmasm PUBLIC ..)