aboutsummaryrefslogtreecommitdiffstats
path: root/liblangutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'liblangutil/CMakeLists.txt')
-rw-r--r--liblangutil/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/liblangutil/CMakeLists.txt b/liblangutil/CMakeLists.txt
index 722ca840..3d8bd37a 100644
--- a/liblangutil/CMakeLists.txt
+++ b/liblangutil/CMakeLists.txt
@@ -1,6 +1,12 @@
# Solidity Commons Library (Solidity related sharing bits between libsolidity and libyul)
-file(GLOB sources "*.cpp")
-file(GLOB headers "*.h")
+set(sources
+ CharStream.cpp
+ ErrorReporter.cpp
+ Exceptions.cpp
+ ParserBase.cpp
+ Scanner.cpp
+ Token.cpp
+)
-add_library(langutil ${sources} ${headers})
+add_library(langutil ${sources})
target_link_libraries(langutil PUBLIC devcore)