aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6a8a4399..f36ad4c5 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -3,7 +3,7 @@ list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/fuzzer.cpp")
file(GLOB_RECURSE headers "*.h")
add_executable(soltest ${sources} ${headers})
-target_link_libraries(soltest PRIVATE soljson solidity lll evmasm devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
+target_link_libraries(soltest PRIVATE libsolc solidity lll evmasm devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
add_executable(solfuzzer fuzzer.cpp)
-target_link_libraries(solfuzzer soljson evmasm ${Boost_PROGRAM_OPTIONS_LIBRARIES})
+target_link_libraries(solfuzzer PRIVATE libsolc evmasm ${Boost_PROGRAM_OPTIONS_LIBRARIES})
5 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826
/* Evolution internal utilities - Glade dialog widget utilities
 *
 * Copyright (C) 2000 Helix Code, Inc.
 *
 * Author: Federico Mena-Quintero <federico@gimp.org>
 *
 * This program is free software; you can redistribute it and/or modify
 * it under the terms of the GNU General Public License as published by
 * the Free Software Foundation; either version 2 of the License, or
 * (at your option) any later version.
 *
 * This program is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 * GNU General Public License for more details.
 *
 * You should have received a copy of the GNU General Public License
 * along with this program; if not, write to the Free Software
 * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA.
 */

#include <config.h>
#include <math.h>
#include <string.h>
#include <time.h>
#include <gtk/gtkmenu.h>
#include <gtk/gtkmenuitem.h>
#include <gtk/gtkoptionmenu.h>
#include <gtk/gtkradiobutton.h>
#include <gtk/gtksignal.h>
#include <gtk/gtkspinbutton.h>
#include <libgnomeui/gnome-dateedit.h>
#include "e-dialog-widgets.h"
#include <gal/widgets/e-unicode.h>



/* A widget, a pointer to the variable it will modify, and extra information */
typedef struct {
    GtkWidget *widget;
    gpointer value_var;
    gpointer info;
} WidgetHook;

/* Hook information for a complete dialog */
typedef struct {
    GSList *whooks;
} DialogHooks;



/* Destroy handler for the dialog; frees the dialog hooks */
static void
dialog_destroy_cb (GtkObject *dialog, gpointer data)
{
    DialogHooks *hooks;

    hooks = data;

    g_slist_free (hooks->whooks);
    hooks->whooks = NULL;

    g_free (hooks);
    gtk_object_set_data (dialog, "dialog-hooks", NULL);
}

/* Ensures that the dialog has the necessary attached data to store the widget
 * hook information.
 */
static DialogHooks *
get_dialog_hooks (GtkWidget *dialog)
{
    DialogHooks *hooks;

    hooks = gtk_object_get_data (GTK_OBJECT (dialog), "dialog-hooks");
    if (!hooks) {
        hooks = g_new0 (DialogHooks, 1);
        gtk_object_set_data (GTK_OBJECT (dialog), "dialog-hooks", hooks);
        gtk_signal_connect (GTK_OBJECT (dialog), "destroy",
                    GTK_SIGNAL_FUNC (dialog_destroy_cb), hooks);
    }

    return hooks;
}

/* Converts an mapped value to the appropriate index in an item group.  The
 * values for the items are provided as a -1-terminated array.
 */
static int
value_to_index (const int *value_map, int value)
{
    int i;

    for (i = 0; value_map[i] != -1; i++)
        if (value_map[i] == value)
            return i;

    return -1;
}

/* Converts an index in an item group to the appropriate mapped value.  See the
 * function above.
 */
static int
index_to_value (const int *value_map, int index)
{
    int i;

    /* We do this the hard way, i.e. not as a simple array reference, to
     * check for correctness.
     */

    for (i = 0; value_map[i] != -1; i++)
        if (i == index)
            return value_map[i];

    return -1;
}

/* Callback for the "toggled" signal of toggle buttons */
static void
toggled_cb (GtkToggleButton *toggle, gpointer data)
{
    GnomePropertyBox *pbox;

    pbox = GNOME_PROPERTY_BOX (data);

    /* For radio buttons, we only notify the property box if the button is
     * active, because we'll get one call for each of the changed buttons in
     * the radio group.
     */
    if (!GTK_IS_RADIO_BUTTON (toggle) || toggle->active)
        gnome_property_box_changed (pbox);
}

/* Hooks a radio button group */
static void
hook_radio (GtkWidget *dialog, GtkRadioButton *radio, gpointer value_var, gpointer info)
{
    GSList *group;
    GSList *l;
    int *value;
    const int *value_map;

    group = gtk_radio_button_group (radio);

    /* Set the value */

    value = (int *) value_var;
    value_map = (const int *) info;

    e_dialog_radio_set (GTK_WIDGET (radio), *value, value_map);

    /* Hook to changed */

    if (GNOME_IS_PROPERTY_BOX (dialog))
        for (l = group; l; l = l->next)
            gtk_signal_connect (GTK_OBJECT (l->data), "toggled",
                        GTK_SIGNAL_FUNC (toggled_cb), dialog);
}

/* Gets the value of a radio button group */
static void
get_radio_value (GtkRadioButton *radio, gpointer value_var, gpointer info)
{
    int *value;
    const int *value_map;

    value = (int *) value_var;
    value_map = (const int *) info;

    *value = e_dialog_radio_get (GTK_WIDGET (radio), value_map);
}

/* Callback for the "activate" signal of menu items */
static void
activate_cb (GtkMenuItem *item, gpointer data)
{
    GnomePropertyBox *pbox;

    pbox = GNOME_PROPERTY_BOX (data);
    gnome_property_box_changed (pbox);
}

/* Hooks an option menu */
static void
hook_option_menu (GtkWidget *dialog, GtkOptionMenu *omenu, gpointer value_var, gpointer info)
{
    int *value;
    const int *value_map;

    /* Set the value */

    value = (int *) value_var;
    value_map = (const int *) info;

    e_dialog_option_menu_set (GTK_WIDGET (omenu), *value, value_map);

    /* Hook to changed */

    if (GNOME_IS_PROPERTY_BOX (dialog)) {
        GtkMenu *menu;
        GList *l;

        menu = GTK_MENU (gtk_option_menu_get_menu (omenu));

        for (l = GTK_MENU_SHELL (menu)->children; l; l = l->next)
            gtk_signal_connect (GTK_OBJECT (l->data), "activate",
                        GTK_SIGNAL_FUNC (activate_cb), dialog);
    }
}

/* Gets the value of an option menu */
static void
get_option_menu_value (GtkOptionMenu *omenu, gpointer value_var, gpointer info)
{
    int *value;
    const int *value_map;

    value = (int *) value_var;
    value_map = (const int *) info;

    *value = e_dialog_option_menu_get (GTK_WIDGET (omenu), value_map);
}

/* Hooks a toggle button */
static void
hook_toggle (GtkWidget *dialog, GtkToggleButton *toggle, gpointer value_var, gpointer info)
{
    gboolean *value;

    /* Set the value */

    value = (gboolean *) value_var;
    e_dialog_toggle_set (GTK_WIDGET (toggle), *value);

    /* Hook to changed */

    if (GNOME_IS_PROPERTY_BOX (dialog))
        gtk_signal_connect (GTK_OBJECT (toggle), "toggled",
                    GTK_SIGNAL_FUNC (toggled_cb), dialog);
}

/* Gets the value of a toggle button */
static void
get_toggle_value (GtkToggleButton *toggle, gpointer value_var, gpointer info)
{
    gboolean *value;

    value = (gboolean *) value_var;
    *value = e_dialog_toggle_get (GTK_WIDGET (toggle));
}

/* Callback for the "value_changed" signal of the adjustment of a spin button */
static void
value_changed_cb (GtkAdjustment *adj, gpointer data)
{
    GnomePropertyBox *pbox;

    pbox = GNOME_PROPERTY_BOX (data);
    gnome_property_box_changed (pbox);
}

/* Hooks a spin button */
static void
hook_spin_button (GtkWidget *dialog, GtkSpinButton *spin, gpointer value_var, gpointer info)
{
    double *value;
    GtkAdjustment *adj;

    /* Set the value */

    value = (double *) value_var;
    e_dialog_spin_set (GTK_WIDGET (spin), *value);

    /* Hook to changed */

    adj = gtk_spin_button_get_adjustment (spin);

    if (GNOME_IS_PROPERTY_BOX (dialog))
        gtk_signal_connect (GTK_OBJECT (adj), "value_changed",
                    GTK_SIGNAL_FUNC (value_changed_cb), dialog);
}

/* Gets the value of a spin button */
static void
get_spin_button_value (GtkSpinButton *spin, gpointer value_var, gpointer info)
{
    double *value;

    value = (double *) value_var;
    *value = e_dialog_spin_get_double (GTK_WIDGET (spin));
}

/* Callback for the "changed" signal of a GtkEditable widget */
static void
changed_cb (GtkEditable *editable, gpointer data)
{
    GnomePropertyBox *pbox;

    pbox = GNOME_PROPERTY_BOX (data);
    gnome_property_box_changed (pbox);
}

/* Hooks a GtkEditable widget */
static void
hook_editable (GtkWidget *dialog, GtkEditable *editable, gpointer value_var, gpointer info)
{
    char **value;

    /* Set the value */

    value = (char **) value_var;

    e_dialog_editable_set (GTK_WIDGET (editable), *value);

    /* Hook to changed */

    if (GNOME_IS_PROPERTY_BOX (dialog))
        gtk_signal_connect (GTK_OBJECT (editable), "changed",
                    GTK_SIGNAL_FUNC (changed_cb), dialog);
}

/* Gets the value of a GtkEditable widget */
static void
get_editable_value (GtkEditable *editable, gpointer value_var, gpointer data)
{
    char **value;

    value = (char **) value_var;
    if (*value)
        g_free (*value);

    *value = e_dialog_editable_get (GTK_WIDGET (editable));
}

/**
 * e_dialog_editable_set:
 * @widget: A #GtkEditable widget.
 * @value: String value.
 * 
 * Sets the string value inside a #GtkEditable-derived widget.
 **/
void
e_dialog_editable_set (GtkWidget *widget, const char *value)
{
    g_return_if_fail (widget != NULL);
    g_return_if_fail (GTK_IS_EDITABLE (widget));

    gtk_editable_delete_text (GTK_EDITABLE (widget), 0, -1);

    if (value) {
        gint pos;

        pos = 0;
        e_utf8_gtk_editable_insert_text (GTK_EDITABLE (widget), value, strlen (value), &pos);
    }
}

/**
 * e_dialog_editable_get:
 * @widget: A #GtkEditable widget.
 * 
 * Queries the string value inside a #GtkEditable-derived widget.
 * 
 * Return value: String value.
 **/
char *
e_dialog_editable_get (GtkWidget *widget)
{
    g_return_val_if_fail (widget != NULL, NULL);
    g_return_val_if_fail (GTK_IS_EDITABLE (widget), NULL);

    return e_utf8_gtk_editable_get_chars (GTK_EDITABLE (widget), 0, -1);
}

/**
 * e_dialog_radio_set:
 * @widget: A #GtkRadioButton in a radio button group.
 * @value: Enumerated value.
 * @value_map: Map from enumeration values to array indices.
 * 
 * Sets the selected item in a radio group.  The specified @widget can be any of
 * the #GtkRadioButtons in the group.  Each radio button should correspond to an
 * enumeration value; the specified @value will be mapped to an integer from
 * zero to the number of items in the group minus 1 by using a mapping table
 * specified in @value_map.  The last element in this table should be -1.  Thus
 * a table to map three possible interpolation values to integers could be
 * specified as { NEAREST_NEIGHBOR, BILINEAR, HYPERBOLIC, -1 }.
 **/
void
e_dialog_radio_set (GtkWidget *widget, int value, const int *value_map)
{
    GSList *group;
    int i;
    GSList *l;

    g_return_if_fail (widget != NULL);
    g_return_if_fail (GTK_IS_RADIO_BUTTON (widget));
    g_return_if_fail (value_map != NULL);

    group = gtk_radio_button_group (GTK_RADIO_BUTTON (widget));

    i = value_to_index (value_map, value);
    if (i != -1) {
        /* Groups are built by prepending items, so the list ends up in reverse
         * order; we need to flip the index around.
         */
        i = g_slist_length (group) - i - 1;

        l = g_slist_nth (group, i);
        if (!l)
            g_message ("e_dialog_radio_set(): could not find index %d in radio group!",
                   i);

        gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (l->data), TRUE);
    } else
        g_message ("e_dialog_radio_set(): could not find value %d in value map!",
               value);
}

/**
 * e_dialog_radio_get:
 * @widget: A #GtkRadioButton in a radio button group.
 * @value_map: Map from enumeration values to array indices.
 * 
 * Queries the selected item in a #GtkRadioButton group.  Please read the
 * description of e_dialog_radio_set() to see how @value_map maps enumeration
 * values to button indices.
 * 
 * Return value: Enumeration value which corresponds to the selected item in the
 * radio group.
 **/
int
e_dialog_radio_get (GtkWidget *widget, const int *value_map)
{
    GSList *group;
    GSList *l;
    int i;
    int v;

    g_return_val_if_fail (widget != NULL, -1);
    g_return_val_if_fail (GTK_IS_RADIO_BUTTON (widget), -1);
    g_return_val_if_fail (value_map != NULL, -1);

    group = gtk_radio_button_group (GTK_RADIO_BUTTON (widget));

    for (i = 0, l = group; l; l = l->next, i++) {
        widget = GTK_WIDGET (l->data);

        if (GTK_TOGGLE_BUTTON (widget)->active)
            break;
    }

    if (!l)
        g_assert_not_reached ();

    /* Groups are built by prepending items, so the list ends up in reverse
     * order; we need to flip the index around.
     */
    i = g_slist_length (group) - i - 1;

    v = index_to_value (value_map, i);
    if (v == -1) {
        g_message ("e_dialog_radio_get(): could not find index %d in value map!", i);
        return -1;
    }

    return v;
}

/**
 * e_dialog_toggle_set:
 * @widget: A #GtkToggleButton.
 * @value: Toggle value.
 * 
 * Sets the value of a #GtkToggleButton-derived widget.  This should not be used
 * for radio buttons; it is more convenient to use use e_dialog_radio_set()
 * instead.
 **/
void
e_dialog_toggle_set (GtkWidget *widget, gboolean value)
{
    g_return_if_fail (widget != NULL);
    g_return_if_fail (GTK_IS_TOGGLE_BUTTON (widget));

    gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (widget), value);
}

/**
 * e_dialog_toggle_get:
 * @widget: A #GtkToggleButton.
 * 
 * Queries the value of a #GtkToggleButton-derived widget.  This should not be
 * used for radio buttons; it is more convenient to use e_dialog_radio_get()
 * instead.
 * 
 * Return value: Toggle value.
 **/
gboolean
e_dialog_toggle_get (GtkWidget *widget)
{
    g_return_val_if_fail (widget != NULL, FALSE);
    g_return_val_if_fail (GTK_IS_TOGGLE_BUTTON (widget), FALSE);

    return GTK_TOGGLE_BUTTON (widget)->active;
}

/**
 * e_dialog_spin_set:
 * @widget: A #GtkSpinButton.
 * @value: Numeric value.
 * 
 * Sets the value of a #GtkSpinButton widget.
 **/
void
e_dialog_spin_set (GtkWidget *widget, double value)
{
    GtkAdjustment *adj;

    g_return_if_fail (widget != NULL);
    g_return_if_fail (GTK_IS_SPIN_BUTTON (widget));

    adj = gtk_spin_button_get_adjustment (GTK_SPIN_BUTTON (widget));

    adj->value = value;
    gtk_signal_emit_by_name (GTK_OBJECT (adj), "value_changed");
}

/**
 * e_dialog_spin_get_double:
 * @widget: A #GtkSpinButton.
 * 
 * Queries the floating-point value of a #GtkSpinButton widget.
 * 
 * Return value: Numeric value.
 **/
double
e_dialog_spin_get_double (GtkWidget *widget)
{
    GtkAdjustment *adj;

    g_return_val_if_fail (widget != NULL, 0.0);
    g_return_val_if_fail (GTK_IS_SPIN_BUTTON (widget), 0.0);

    adj = gtk_spin_button_get_adjustment (GTK_SPIN_BUTTON (widget));
    return adj->value;
}

/**
 * e_dialog_spin_get_int:
 * @widget: A #GtkSpinButton.
 * 
 * Queries the integer value of a #GtkSpinButton widget.
 * 
 * Return value: Numeric value.
 **/
int
e_dialog_spin_get_int (GtkWidget *widget)
{
    double value;

    g_return_val_if_fail (widget != NULL, -1);
    g_return_val_if_fail (GTK_IS_SPIN_BUTTON (widget), -1);

    value = e_dialog_spin_get_double (widget);
    return (int) floor (value);
}

/**
 * e_dialog_option_menu_set:
 * @widget: A #GtkOptionMenu.
 * @value: Enumerated value.
 * @value_map: Map from enumeration values to array indices.
 * 
 * Sets the selected item in a #GtkOptionMenu.  Please read the description of
 * e_dialog_radio_set() to see how @value_map maps enumeration values to item
 * indices.
 **/
void
e_dialog_option_menu_set (GtkWidget *widget, int value, const int *value_map)
{
    int i;

    g_return_if_fail (widget != NULL);
    g_return_if_fail (GTK_IS_OPTION_MENU (widget));
    g_return_if_fail (value_map != NULL);

    i = value_to_index (value_map, value);

    if (i != -1)
        gtk_option_menu_set_history (GTK_OPTION_MENU (widget), i);
    else
        g_message ("e_dialog_option_menu_set(): could not find value %d in value map!",
               value);
}

/**
 * e_dialog_option_menu_get:
 * @widget: A #GtkOptionMenu.
 * @value_map: Map from enumeration values to array indices.
 * 
 * Queries the selected item in a #GtkOptionMenu.  Please read the description
 * of e_dialog_radio_set() to see how @value_map maps enumeration values to item
 * indices.
 * 
 * Return value: Enumeration value which corresponds to the selected item in the
 * option menu.
 **/
int
e_dialog_option_menu_get (GtkWidget *widget, const int *value_map)
{
    GtkMenu *menu;
    GtkWidget *active;
    GList *children;
    GList *l;
    int i;
    int v;

    g_return_val_if_fail (widget != NULL, -1);
    g_return_val_if_fail (GTK_IS_OPTION_MENU (widget), -1);
    g_return_val_if_fail (value_map != NULL, -1);

    menu = GTK_MENU (gtk_option_menu_get_menu (GTK_OPTION_MENU (widget)));

    active = gtk_menu_get_active (menu);
    g_assert (active != NULL);

    children = GTK_MENU_SHELL (menu)->children;

    for (i = 0, l = children; l; l = l->next, i++) {
        if (GTK_WIDGET (l->data) == active)
            break;
    }

    if (!l)
        g_assert_not_reached ();

    v = index_to_value (value_map, i);
    if (v == -1) {
        g_message ("e_dialog_option_menu_get(): could not find index %d in value map!", i);
        return -1;
    }

    return v;
}

/**
 * e_dialog_dateedit_set:
 * @widget: A #GnomeDateEdit widget.
 * @t: Date/time value.
 * 
 * Sets the value of a #GnomeDateEdit widget.
 **/
void
e_dialog_dateedit_set (GtkWidget *widget, time_t t)
{
    g_return_if_fail (widget != NULL);
    g_return_if_fail (GNOME_IS_DATE_EDIT (widget));

    gnome_date_edit_set_time (GNOME_DATE_EDIT (widget), t);
}

/**
 * e_dialog_dateedit_get:
 * @widget: A #GnomeDateEdit widget.
 * 
 * Queries the value of a #GnomeDateEdit widget.
 * 
 * Return value: Date/time value.
 **/
time_t
e_dialog_dateedit_get (GtkWidget *widget)
{
    g_return_val_if_fail (widget != NULL, -1);
    g_return_val_if_fail (GNOME_IS_DATE_EDIT (widget), -1);

    return gnome_date_edit_get_date (GNOME_DATE_EDIT (widget));
}

/**
 * e_dialog_widget_hook_value:
 * @dialog: Dialog box in which the @widget lives in.
 * @widget: A widget that will control a variable.
 * @value_var: Pointer to the variable that the @widget will control.
 * @info: NULL for most widgets, or an integer value map array (see
 * e_dialog_radio_set() for details).
 * 
 * Hooks a widget from a dialog box to the variable it will modify.  Supported
 * widgets are:  #GtkEditable (char *), #GtkRadioButton (int/value_map pair; see
 * e_dialog_radio_set() for more information), #GtkTogglebutton (gboolean),
 * #GtkSpinButton (double), #GtkOptionMenu (int/value_map pair), and
 * #GnomeDateEdit (time_t).
 *
 * A pointer to the appropriate variable to modify should be passed in @value_var.
 * For values that take a value_map array as well, it should be passed in @info.
 *
 * The widgets within a dialog that are hooked with this function will set their