Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | libyul: changing some AST members from shared_ptr<> to unique_ptr<> | Christian Parpart | 2019-01-16 | 1 | -6/+6 |
| | | | | | * Some spaces look a little more verbose now, but that shouln't be a problem as it also should raise readability, too. * This makes some use of return-value-optimizations also. | ||||
* | Disallow mismatching types in switch cases and detect duplicates by value ↵ | Daniel Kirchner | 2019-01-15 | 1 | -1/+1 |
| | | | | for number literals. | ||||
* | Adjust inlining thresholds. | chriseth | 2019-01-09 | 1 | -5/+9 |
| | |||||
* | Do not create unassigned variables. | chriseth | 2018-12-13 | 1 | -0/+4 |
| | |||||
* | Do not inline into already big functions. | chriseth | 2018-12-13 | 1 | -3/+16 |
| | |||||
* | Relax dependency of FullInliner on FunctionHoister. | Daniel Kirchner | 2018-12-05 | 1 | -10/+14 |
| | |||||
* | Isolating libyul library API into its own namespace `yul`. | Christian Parpart | 2018-11-23 | 1 | -1/+1 |
| | |||||
* | Reorder some include files and group <libyul/>'s together (as much as possible) | Christian Parpart | 2018-11-23 | 1 | -1/+0 |
| | |||||
* | Rewrite header paths to adapt to recent `git mv` of libsolidity/inlineasm to ↵ | Christian Parpart | 2018-11-23 | 1 | -1/+1 |
| | | | | libyul | ||||
* | Performance: Replace string by special single-copy YulString class. | chriseth | 2018-11-08 | 1 | -9/+9 |
| | |||||
* | Make full inliner more flexible. | chriseth | 2018-10-18 | 1 | -10/+9 |
| | |||||
* | Merge pull request #5240 from ethereum/limitDispenserSize | chriseth | 2018-10-18 | 1 | -10/+4 |
|\ | | | | | [Yul] Limit name length created by dispenser | ||||
| * | Limit size of generated names and add convenience constructors. | chriseth | 2018-10-17 | 1 | -10/+4 |
| | | |||||
* | | Use metrics in the full inliner. | chriseth | 2018-10-17 | 1 | -8/+53 |
|/ | |||||
* | Inline each function separately. | chriseth | 2018-10-16 | 1 | -23/+12 |
| | |||||
* | New full inliner. | chriseth | 2018-10-16 | 1 | -148/+80 |
| | |||||
* | Renaming namespace dev::julia to dev::yul. | Christian Parpart | 2018-10-15 | 1 | -1/+1 |
| | |||||
* | Renaming libjulia to libyul | Christian Parpart | 2018-10-15 | 1 | -0/+264 |