aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-02-26 15:24:19 +0800
committertg <tg@FreeBSD.org>1998-02-26 15:24:19 +0800
commit63393e1584da5f69068eb4b1a99e893f97727ac4 (patch)
tree64dcfc93944944d3619bf4a83e444cf9dc08b832
parentb66acd6c7b2bc12a474f0778c16cea5fe2f780d8 (diff)
downloadfreebsd-ports-gnome-63393e1584da5f69068eb4b1a99e893f97727ac4.tar.gz
freebsd-ports-gnome-63393e1584da5f69068eb4b1a99e893f97727ac4.tar.zst
freebsd-ports-gnome-63393e1584da5f69068eb4b1a99e893f97727ac4.zip
Actually use all those libs this ports depends on.
Reviewed by: maintainer
-rw-r--r--x11-wm/windowmaker-i18n/Makefile10
-rw-r--r--x11-wm/windowmaker/Makefile10
2 files changed, 14 insertions, 6 deletions
diff --git a/x11-wm/windowmaker-i18n/Makefile b/x11-wm/windowmaker-i18n/Makefile
index cf6d309e5167..f9fd9967613b 100644
--- a/x11-wm/windowmaker-i18n/Makefile
+++ b/x11-wm/windowmaker-i18n/Makefile
@@ -3,7 +3,7 @@
# Date created: August 13, 1997
# Whom: handy@physics.montana.edu
#
-# $Id: Makefile,v 1.1.1.1 1997/11/04 10:33:43 tg Exp $
+# $Id: Makefile,v 1.2 1998/02/24 09:16:48 tg Exp $
DISTNAME= WindowMaker-0.13.1
PKGNAME= windowmaker-0.13.1
@@ -22,7 +22,11 @@ LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
USE_X11= yes
USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-nlsdir=${LOCALBASE}/lib/locale
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= X11BASE=${X11BASE}
+CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
+ --with-nlsdir=${LOCALBASE}/lib/locale \
+ --with-gfx-libs=-L${LOCALBASE}/lib \
+ --with-gfx-incs="-I${LOCALBASE}/include/tiff34 -I${LOCALBASE}/include"
.include <bsd.port.mk>
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index cf6d309e5167..f9fd9967613b 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,7 +3,7 @@
# Date created: August 13, 1997
# Whom: handy@physics.montana.edu
#
-# $Id: Makefile,v 1.1.1.1 1997/11/04 10:33:43 tg Exp $
+# $Id: Makefile,v 1.2 1998/02/24 09:16:48 tg Exp $
DISTNAME= WindowMaker-0.13.1
PKGNAME= windowmaker-0.13.1
@@ -22,7 +22,11 @@ LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
USE_X11= yes
USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-nlsdir=${LOCALBASE}/lib/locale
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= X11BASE=${X11BASE}
+CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
+ --with-nlsdir=${LOCALBASE}/lib/locale \
+ --with-gfx-libs=-L${LOCALBASE}/lib \
+ --with-gfx-incs="-I${LOCALBASE}/include/tiff34 -I${LOCALBASE}/include"
.include <bsd.port.mk>