aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-10-04 23:00:39 +0800
committerjkh <jkh@FreeBSD.org>1994-10-04 23:00:39 +0800
commit99e59679c048de48dec505b3bf8161af99b2f5cf (patch)
tree2e7cd1f3487a8f8a8a92dec8e307c9afec1218a1
parent93a1bd6c5c60a8dbc87a70f732af76df554bee80 (diff)
downloadfreebsd-ports-gnome-99e59679c048de48dec505b3bf8161af99b2f5cf.tar.gz
freebsd-ports-gnome-99e59679c048de48dec505b3bf8161af99b2f5cf.tar.zst
freebsd-ports-gnome-99e59679c048de48dec505b3bf8161af99b2f5cf.zip
Michael Elbel's port of seyon.
-rw-r--r--comms/seyon/Makefile16
-rw-r--r--comms/seyon/files/patch-aa87
-rw-r--r--comms/seyon/pkg-comment1
-rw-r--r--comms/seyon/pkg-descr23
-rw-r--r--comms/seyon/pkg-plist9
5 files changed, 136 insertions, 0 deletions
diff --git a/comms/seyon/Makefile b/comms/seyon/Makefile
new file mode 100644
index 000000000000..13fbffbe146d
--- /dev/null
+++ b/comms/seyon/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: seyon
+# Version required: 2.14b or 2.14c
+# Date created: 3 October 1994
+# Whom: Michael Elbel (me)
+#
+# $$
+#
+
+DISTNAME= Seyon-2.14c
+DISTFILES= Seyon-2.14c-tar.gz
+WRKSRC= ${WRKDIR}/seyon
+USE_IMAKE= yes
+MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/X11/xapps/comm/
+
+
+.include <bsd.port.mk>
diff --git a/comms/seyon/files/patch-aa b/comms/seyon/files/patch-aa
new file mode 100644
index 000000000000..0a1476578424
--- /dev/null
+++ b/comms/seyon/files/patch-aa
@@ -0,0 +1,87 @@
+Only in seyon: Makefile
+diff -c SePort.c seyon.new/SePort.c
+*** SePort.c Wed Apr 21 15:38:31 1993
+--- seyon.new/SePort.c Sun Oct 2 23:05:25 1994
+***************
+*** 627,645 ****
+ #endif
+ break;
+ #if USE_NONSTD_BAUD
+- #ifdef linux
+ case 57600:
+ baudrate = B38400;
+ ser_io.flags &= ~ASYNC_SPD_MASK;
+ ser_io.flags |= ASYNC_SPD_HI;
+ break;
+ case 115200:
+ baudrate = B38400;
+ ser_io.flags &= ~ASYNC_SPD_MASK;
+ ser_io.flags |= ASYNC_SPD_VHI;
+ break;
+ #endif
+- #endif
+ default:
+ return (-1);
+ }
+--- 627,651 ----
+ #endif
+ break;
+ #if USE_NONSTD_BAUD
+ case 57600:
++ #ifdef linux
+ baudrate = B38400;
+ ser_io.flags &= ~ASYNC_SPD_MASK;
+ ser_io.flags |= ASYNC_SPD_HI;
++ #else
++ baudrate = B57600;
++ #endif
+ break;
+ case 115200:
++ #ifdef linux
+ baudrate = B38400;
+ ser_io.flags &= ~ASYNC_SPD_MASK;
+ ser_io.flags |= ASYNC_SPD_VHI;
++ #else
++ baudrate = B115200;
++ #endif
+ break;
+ #endif
+ default:
+ return (-1);
+ }
+***************
+*** 691,696 ****
+--- 697,710 ----
+ #endif
+ #endif
+ return 38400;
++ #if USE_NONSTD_BAUD
++ #ifndef linux
++ case B57600:
++ return(57600);
++ case B115200:
++ return(115200);
++ #endif
++ #endif
+ }
+
+ SeError("Consistency error in baud rate");
+diff -c config.h seyon.new/config.h
+*** config.h Wed Apr 21 14:47:48 1993
+--- seyon.new/config.h Sun Oct 2 23:03:53 1994
+***************
+*** 81,86 ****
+--- 81,92 ----
+ #define HAVE_USLEEP YES
+ #endif
+
++ #ifdef __FreeBSD__
++ #define USE_NONSTD_BAUD YES
++ #define LF_PATH "/var/spool/lock"
++ #define LF_PREFIX "LCK.."
++ #endif
++
+ #ifdef SVR4
+ #define HAVE_TERMIOS YES
+ #define HAVE_MODEM_CONTROL YES
+
diff --git a/comms/seyon/pkg-comment b/comms/seyon/pkg-comment
new file mode 100644
index 000000000000..77dbfe8d625a
--- /dev/null
+++ b/comms/seyon/pkg-comment
@@ -0,0 +1 @@
+The Seyon communications package for the X Window system, version 2.14c \ No newline at end of file
diff --git a/comms/seyon/pkg-descr b/comms/seyon/pkg-descr
new file mode 100644
index 000000000000..8899a51560ec
--- /dev/null
+++ b/comms/seyon/pkg-descr
@@ -0,0 +1,23 @@
+Seyon is a complete full-featured telecommunications package for
+the X Window System. Its features include:
+
+ - Dialing directory that supports an unlimited number of entries.
+ - Terminal emulation window using any terminal emulation program
+ that supports X. This defaults to xterm.
+ - Script language to automate tedious tasks such as logging into
+ remote hosts.
+ - Unlimited number of slots for external file transfer protocols.
+ - Support for zmodem auto-download.
+ - Translation modes. Seyon can perfrom useful trasnlations on the
+ user's input.
+ - interactive setting of program parameters
+ - on-line help
+ - modem speeds up to 115200 bps
+ - software (XON/XOFF) and hardware (RTS/CTS) flow control
+ - session capture to a file
+ - temporary running of a local shell in the terminal emulation window.
+
+Seyon is intended to be both simple and extensively configurable.
+Almost every aspect of Seyon can be configured via the resources
+to suit the user's taste.
+
diff --git a/comms/seyon/pkg-plist b/comms/seyon/pkg-plist
new file mode 100644
index 000000000000..e2d557272aa8
--- /dev/null
+++ b/comms/seyon/pkg-plist
@@ -0,0 +1,9 @@
+@cd /usr/X11R6
+@mode 755
+@owner bin
+@group bin
+bin/seyon
+@mode 444
+lib/X11/app-defaults/Seyon
+lib/X11/app-defaults/Seyon-color
+lib/X11/seyon.help