aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-12-11 16:11:23 +0800
committerobrien <obrien@FreeBSD.org>1998-12-11 16:11:23 +0800
commit9e282c242a9dfead954607a7bdd29e518d677948 (patch)
tree1ae2ad18119d5afba5e07517ca06e7875469448c
parent67ae5fda60dff3e1cb52c940060c7f8e919f72b8 (diff)
downloadfreebsd-ports-gnome-9e282c242a9dfead954607a7bdd29e518d677948.tar.gz
freebsd-ports-gnome-9e282c242a9dfead954607a7bdd29e518d677948.tar.zst
freebsd-ports-gnome-9e282c242a9dfead954607a7bdd29e518d677948.zip
Abstract the building of netscape.sh a little bit.
-rw-r--r--www/bsdi-netscape47-communicator/Makefile12
-rw-r--r--www/netscape47-communicator/Makefile12
2 files changed, 12 insertions, 12 deletions
diff --git a/www/bsdi-netscape47-communicator/Makefile b/www/bsdi-netscape47-communicator/Makefile
index fd1a8bde7a0f..23f9762a6ace 100644
--- a/www/bsdi-netscape47-communicator/Makefile
+++ b/www/bsdi-netscape47-communicator/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1997
# Whom: thepish
#
-# $Id: Makefile,v 1.31 1998/11/28 09:00:33 obrien Exp $
+# $Id: Makefile,v 1.32 1998/12/03 22:08:48 billf Exp $
#
DISTNAME= communicator-v45-export.x86-unknown-freebsd
@@ -24,6 +24,7 @@ NO_FILTER_SHLIBS=yes
NDIRBASE= netscape-4.5
NDIR= ${PREFIX}/${NDIRBASE}
BINDIR= ${PREFIX}/bin
+NBIN= communicator-4.5.bin
.if defined(USE_128BIT)
MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
@@ -36,20 +37,19 @@ pre-extract:
.endif # USE_128BIT
post-configure:
- ${SED} -e "s;@X11BASE@;${X11BASE};g" \
- -e "s;@PREFIX@;${PREFIX};g" \
- -e "s;@NDIR@;${NDIR};g" \
+ ${SED} -e "s;@NDIR@;${NDIR};g" \
+ -e "s;@NBIN@;${NBIN};g" \
${FILESDIR}/netscape.sh >${WRKSRC}/netscape
do-install:
cd ${WRKSRC} && \
- yes "" | LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
+ yes "" | LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
${MV} -f ${NDIR}/netscape ${NDIR}/communicator-4.5.bin
${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/communicator-4.5
${LN} -sf communicator-4.5 ${BINDIR}/communicator-4
${LN} -sf communicator-4 ${BINDIR}/netscape
if [ ! -f ${NDIR}/mailcap ] ; then \
- ${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
+ ${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/movemail-src
.if defined(USE_128BIT)
diff --git a/www/netscape47-communicator/Makefile b/www/netscape47-communicator/Makefile
index fd1a8bde7a0f..23f9762a6ace 100644
--- a/www/netscape47-communicator/Makefile
+++ b/www/netscape47-communicator/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1997
# Whom: thepish
#
-# $Id: Makefile,v 1.31 1998/11/28 09:00:33 obrien Exp $
+# $Id: Makefile,v 1.32 1998/12/03 22:08:48 billf Exp $
#
DISTNAME= communicator-v45-export.x86-unknown-freebsd
@@ -24,6 +24,7 @@ NO_FILTER_SHLIBS=yes
NDIRBASE= netscape-4.5
NDIR= ${PREFIX}/${NDIRBASE}
BINDIR= ${PREFIX}/bin
+NBIN= communicator-4.5.bin
.if defined(USE_128BIT)
MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
@@ -36,20 +37,19 @@ pre-extract:
.endif # USE_128BIT
post-configure:
- ${SED} -e "s;@X11BASE@;${X11BASE};g" \
- -e "s;@PREFIX@;${PREFIX};g" \
- -e "s;@NDIR@;${NDIR};g" \
+ ${SED} -e "s;@NDIR@;${NDIR};g" \
+ -e "s;@NBIN@;${NBIN};g" \
${FILESDIR}/netscape.sh >${WRKSRC}/netscape
do-install:
cd ${WRKSRC} && \
- yes "" | LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
+ yes "" | LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
${MV} -f ${NDIR}/netscape ${NDIR}/communicator-4.5.bin
${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/communicator-4.5
${LN} -sf communicator-4.5 ${BINDIR}/communicator-4
${LN} -sf communicator-4 ${BINDIR}/netscape
if [ ! -f ${NDIR}/mailcap ] ; then \
- ${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
+ ${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/movemail-src
.if defined(USE_128BIT)