aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-24 21:43:36 +0800
committerbapt <bapt@FreeBSD.org>2014-03-24 21:43:36 +0800
commitbe48bf7c7efb2af21ad3d242a1d80106d40fee6f (patch)
tree28a993dc393cd52456155f57f04d45ccc51dec49
parentb9484b57b24e5007446ded1e5fee0f4113a4d08e (diff)
downloadfreebsd-ports-gnome-be48bf7c7efb2af21ad3d242a1d80106d40fee6f.tar.gz
freebsd-ports-gnome-be48bf7c7efb2af21ad3d242a1d80106d40fee6f.tar.zst
freebsd-ports-gnome-be48bf7c7efb2af21ad3d242a1d80106d40fee6f.zip
Mark as broken ports that expect wx 2.9+ but does not build with 3.0 (2.9 is a dev version and will be removed soon)
-rw-r--r--emulators/wxmupen64plus/Makefile2
-rw-r--r--net-p2p/solidcoin/Makefile2
-rw-r--r--x11-toolkits/hs-wx/Makefile2
-rw-r--r--x11-toolkits/hs-wxc/Makefile2
-rw-r--r--x11-toolkits/hs-wxcore/Makefile2
5 files changed, 10 insertions, 0 deletions
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
index 14eb977a7355..e47c31709751 100644
--- a/emulators/wxmupen64plus/Makefile
+++ b/emulators/wxmupen64plus/Makefile
@@ -13,6 +13,8 @@ DIST_SUBDIR= ${PORTNAME:S/wx//}
MAINTAINER= acm@FreeBSD.org
COMMENT= Mupen64Plus 2.0 GUI frontend written using wxWidgets
+BROKEN= does not build with any of the supported wx
+
LIB_DEPENDS= mupen64plus:${PORTSDIR}/emulators/mupen64plus-core
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl \
diff --git a/net-p2p/solidcoin/Makefile b/net-p2p/solidcoin/Makefile
index 16e24985b625..71ef78548929 100644
--- a/net-p2p/solidcoin/Makefile
+++ b/net-p2p/solidcoin/Makefile
@@ -17,6 +17,8 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/parallel/algorithm.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs
+BROKEN= Does not build with any of the supported wx
+
OPTIONS_DEFINE= WXGTK
OPTIONS_DEFAULT= WXGTK
diff --git a/x11-toolkits/hs-wx/Makefile b/x11-toolkits/hs-wx/Makefile
index 49125ff772e1..97ad3eb58d00 100644
--- a/x11-toolkits/hs-wx/Makefile
+++ b/x11-toolkits/hs-wx/Makefile
@@ -10,6 +10,8 @@ COMMENT= wxHaskell
USE_CABAL= stm wxcore>=0.90
+BROKEN= does not build with any of the supported wx
+
USE_WX= 3.0
WX_COMPS= wx
WX_UNICODE= yes
diff --git a/x11-toolkits/hs-wxc/Makefile b/x11-toolkits/hs-wxc/Makefile
index bc12f340a239..7be9e87de7ae 100644
--- a/x11-toolkits/hs-wxc/Makefile
+++ b/x11-toolkits/hs-wxc/Makefile
@@ -10,6 +10,8 @@ COMMENT= wxHaskell C++ wrapper
USE_CABAL= wxdirect>=0.90
+BROKEN= does not build with any of the supported wx
+
USE_WX= 3.0
WX_COMPS= wx
WX_UNICODE= yes
diff --git a/x11-toolkits/hs-wxcore/Makefile b/x11-toolkits/hs-wxcore/Makefile
index 06175ac0cf50..9cba613bd1ca 100644
--- a/x11-toolkits/hs-wxcore/Makefile
+++ b/x11-toolkits/hs-wxcore/Makefile
@@ -10,6 +10,8 @@ COMMENT= wxHaskell core
USE_CABAL= parsec stm wxc>=0.90.0.4 wxdirect>=0.90
+BROKEN= does not build with any of the supported wx
+
USE_WX= 3.0
WX_COMPS= wx
WX_UNICODE= yes