aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1995-10-16 22:27:20 +0800
committerache <ache@FreeBSD.org>1995-10-16 22:27:20 +0800
commit5cac15a6a418e8927b8e8daf961de93ac7f20ead (patch)
tree10545fe78f47a610aa426d2c7c1cb6e95b95a151 /Mk
parentf67e5c2b2eb39c0c6e7d3027aec06e1109484a1a (diff)
downloadfreebsd-ports-gnome-5cac15a6a418e8927b8e8daf961de93ac7f20ead.tar.gz
freebsd-ports-gnome-5cac15a6a418e8927b8e8daf961de93ac7f20ead.tar.zst
freebsd-ports-gnome-5cac15a6a418e8927b8e8daf961de93ac7f20ead.zip
Add NO_FETCH handling in the similar way as other NO_* targets does
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8283bc64bf1c..f921f4107d0a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.183 1995/10/11 09:25:58 asami Exp $
+# $Id: bsd.port.mk,v 1.184 1995/10/16 14:18:22 ache Exp $
#
# Please view me with 4 column tabs!
@@ -427,6 +427,10 @@ is_depended: ${IS_DEPENDED_TARGET}
# override from an individual Makefile.
################################################################
+.if defined(NO_FETCH) && !target(fetch)
+fetch:
+ @${DO_NADA}
+.endif
.if defined(NO_EXTRACT) && !target(extract)
extract: checksum
@/bin/rm -rf ${WRKDIR}