aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoradam <adam@FreeBSD.org>1994-08-31 00:39:27 +0800
committeradam <adam@FreeBSD.org>1994-08-31 00:39:27 +0800
commit91522a76bde2bd74a7ac47d8f3fd313398179b1b (patch)
tree99a04f7c4946ee26eeef523fe4c6165b06e57d8d /Mk
parent934155fdcfc257a0a399568d3bec4f14572cf880 (diff)
downloadfreebsd-ports-gnome-91522a76bde2bd74a7ac47d8f3fd313398179b1b.tar.gz
freebsd-ports-gnome-91522a76bde2bd74a7ac47d8f3fd313398179b1b.tar.zst
freebsd-ports-gnome-91522a76bde2bd74a7ac47d8f3fd313398179b1b.zip
added hook for post-build script
Reviewed by: Submitted by:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5f931a5c65d0..9d144a582c2c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.20 1994/08/25 22:59:56 jkh Exp $
+# $Id: bsd.port.mk,v 1.21 1994/08/28 14:41:34 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -191,6 +191,9 @@ build: configure pre-build
.else defined(USE_GMAKE)
@(cd ${WRKSRC}; ${MAKE} all)
.endif
+ @if [ -f ${SCRIPTDIR}/post-build ]; then \
+ sh ${SCRIPTDIR}/post-build ${PORTSDIR} ${.CURDIR} ${WRKSRC}; \
+ fi
.endif
.if !target(pre-configure)