aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/pyDict
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2000-10-15 08:20:24 +0800
committersada <sada@FreeBSD.org>2000-10-15 08:20:24 +0800
commit475b6a399abbac51e370ed95e5ff552d3355cfd3 (patch)
tree09b36a2d212947c48c96f8b48824574a7c8d3de0 /chinese/pyDict
parent198c67ec5d218cd87d7843e6597128cde7c4e862 (diff)
downloadfreebsd-ports-gnome-475b6a399abbac51e370ed95e5ff552d3355cfd3.tar.gz
freebsd-ports-gnome-475b6a399abbac51e370ed95e5ff552d3355cfd3.tar.zst
freebsd-ports-gnome-475b6a399abbac51e370ed95e5ff552d3355cfd3.zip
New port: chinese/pyDict.
From pkg-descr: pyDict is a Chinese(Big5) <-> English dictionary, written in Python. It can be used as a console app or X11 window(with -x option). The data is prepared by TurboLinux in simplified Chinese, then converted to traditional Chinese by CLE(Chinese Linux Extension) team. PR: ports/14643 Submitted by: Jing-Tang Keith Jang <keith@freebsd.sinica.edu.tw>
Diffstat (limited to 'chinese/pyDict')
-rw-r--r--chinese/pyDict/Makefile41
-rw-r--r--chinese/pyDict/distinfo1
-rw-r--r--chinese/pyDict/files/gtkrc.zh_TW.big5.sample6
-rw-r--r--chinese/pyDict/files/patch-aa38
-rw-r--r--chinese/pyDict/pkg-comment1
-rw-r--r--chinese/pyDict/pkg-descr6
-rw-r--r--chinese/pyDict/pkg-message8
-rw-r--r--chinese/pyDict/pkg-plist36
8 files changed, 137 insertions, 0 deletions
diff --git a/chinese/pyDict/Makefile b/chinese/pyDict/Makefile
new file mode 100644
index 000000000000..2760d7cbe519
--- /dev/null
+++ b/chinese/pyDict/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pyDict
+# Date created: 25 Oct 1999
+# Whom: Jing-Tang Keith Jang <keith@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyDict
+PORTVERSION= 0.2.5
+PORTREVISION= 1
+CATEGORIES= chinese
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
+DISTNAME= pyDict-0.2.5.1
+
+MAINTAINER= keith@freebsd.sinica.edu.tw
+
+RUN_DEPENDS= ${LOCALBASE}/include/pygtk/pygtk.h:${PORTSDIR}/x11-toolkits/py-gtk \
+ ${X11BASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf
+
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/dict
+NO_BUILD= yes
+SHAREMODE= 644
+DICTDIR= ${PREFIX}/lib/X11/pyDict
+DOCDIR= ${PREFIX}/share/doc/pyDict
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${DICTDIR}
+ @${INSTALL_DATA} ${WRKSRC}/[a-z].lib ${WRKSRC}/dict.xpm ${WRKSRC}/yaba.xpm ${WRKSRC}/HELP ${DICTDIR}
+ @${INSTALL_DATA} ${FILESDIR}/gtkrc.zh_TW.big5.sample ${DICTDIR}
+ @${MKDIR} ${DOCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${WRKSRC}/COPYING ${WRKSRC}/README ${DOCDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/dict.py ${PREFIX}/bin/pydict
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/chinese/pyDict/distinfo b/chinese/pyDict/distinfo
new file mode 100644
index 000000000000..447ca8e76ae2
--- /dev/null
+++ b/chinese/pyDict/distinfo
@@ -0,0 +1 @@
+MD5 (pyDict-0.2.5.1.tar.gz) = ec92b0ed24ee48e483b1d4ea3713c012
diff --git a/chinese/pyDict/files/gtkrc.zh_TW.big5.sample b/chinese/pyDict/files/gtkrc.zh_TW.big5.sample
new file mode 100644
index 000000000000..205a26cb8b7f
--- /dev/null
+++ b/chinese/pyDict/files/gtkrc.zh_TW.big5.sample
@@ -0,0 +1,6 @@
+style "default" {
+ fontset = "-adobe-helvetica-medium-r-normal--14-100-100-100-p-76-iso8859-1,\
+ -*-medium-r-normal--14-*-*-*-*-*-big5-0"
+}
+class "GtkWidget" style "default"
+
diff --git a/chinese/pyDict/files/patch-aa b/chinese/pyDict/files/patch-aa
new file mode 100644
index 000000000000..b2d8ef7bbaad
--- /dev/null
+++ b/chinese/pyDict/files/patch-aa
@@ -0,0 +1,38 @@
+--- dict.py.orig Wed Oct 4 14:37:47 2000
++++ dict.py Wed Oct 4 15:03:58 2000
+@@ -252,7 +252,7 @@
+ def execute(self,word): # English to Chinese
+ # move self.index to top
+ self.index = 0
+- command = g_command + ' --after-context=20 "^' + word + '.*=.*$" ' + dict_path + lower(word[0]) + '.lib' + '|awk "NR < 19 "'
++ command = g_command + ' -A 20 "^' + word + '.*=.*$" ' + dict_path + lower(word[0]) + '.lib' + '|awk "NR < 19 "'
+ result_lines = os.popen(command,'r').readlines()
+ #if result_lines:
+ if result_lines:
+@@ -488,7 +488,7 @@
+
+ def console_e_dict(input=None):
+ #set up g_command
+- g_command = '/bin/grep --ignore-case'
++ g_command = '/usr/bin/grep --ignore-case'
+ if input == None:
+ inp = raw_input('word:')
+ else:
+@@ -532,7 +532,7 @@
+
+ def console_c_dict(input=None):
+ #set up g_command
+- g_command = '/bin/grep '
++ g_command = '/usr/bin/grep '
+ if input == None:
+ inp = raw_input('word:')
+ else:
+@@ -603,7 +603,7 @@
+ print 'type -e to English-Chinese mode'
+
+ # set up grep command
+- g_command = '/bin/grep --ignore-case'
++ g_command = '/usr/bin/grep --ignore-case'
+ dict_path = '/usr/X11R6/lib/X11/pyDict/'
+
+ # check if there is an DISPLAY environment variable
diff --git a/chinese/pyDict/pkg-comment b/chinese/pyDict/pkg-comment
new file mode 100644
index 000000000000..cbc271709aaf
--- /dev/null
+++ b/chinese/pyDict/pkg-comment
@@ -0,0 +1 @@
+A Chinese <-> English dictionary, under both console and X11
diff --git a/chinese/pyDict/pkg-descr b/chinese/pyDict/pkg-descr
new file mode 100644
index 000000000000..33db46f5a03e
--- /dev/null
+++ b/chinese/pyDict/pkg-descr
@@ -0,0 +1,6 @@
+pyDict is a Chinese(Big5) <-> English dictionary, written in Python.
+It can be used as a console app or X11 window(with -x option). The
+data is prepared by TurboLinux in simplified Chinese, then converted
+to traditional Chinese by CLE(Chinese Linux Extension) team.
+
+Author: Daniel Gau <plateau@pagic.net>
diff --git a/chinese/pyDict/pkg-message b/chinese/pyDict/pkg-message
new file mode 100644
index 000000000000..1f735c1dc1bb
--- /dev/null
+++ b/chinese/pyDict/pkg-message
@@ -0,0 +1,8 @@
+
+---------------------------------------------------------
+If you experience problems displaying Chinese, first make
+sure that you have correct locale settings, then copy
+/usr/X11R6/lib/X11/pyDict/gtkrc.zh_TW.big5.sample to
+~/.gtkrc.zh_TW.big5 and try again.
+---------------------------------------------------------
+
diff --git a/chinese/pyDict/pkg-plist b/chinese/pyDict/pkg-plist
new file mode 100644
index 000000000000..6bb7d07a79ce
--- /dev/null
+++ b/chinese/pyDict/pkg-plist
@@ -0,0 +1,36 @@
+bin/pydict
+lib/X11/pyDict/HELP
+lib/X11/pyDict/gtkrc.zh_TW.big5.sample
+lib/X11/pyDict/a.lib
+lib/X11/pyDict/b.lib
+lib/X11/pyDict/c.lib
+lib/X11/pyDict/d.lib
+lib/X11/pyDict/dict.xpm
+lib/X11/pyDict/e.lib
+lib/X11/pyDict/f.lib
+lib/X11/pyDict/g.lib
+lib/X11/pyDict/h.lib
+lib/X11/pyDict/i.lib
+lib/X11/pyDict/j.lib
+lib/X11/pyDict/k.lib
+lib/X11/pyDict/l.lib
+lib/X11/pyDict/m.lib
+lib/X11/pyDict/n.lib
+lib/X11/pyDict/o.lib
+lib/X11/pyDict/p.lib
+lib/X11/pyDict/q.lib
+lib/X11/pyDict/r.lib
+lib/X11/pyDict/s.lib
+lib/X11/pyDict/t.lib
+lib/X11/pyDict/u.lib
+lib/X11/pyDict/v.lib
+lib/X11/pyDict/w.lib
+lib/X11/pyDict/x.lib
+lib/X11/pyDict/y.lib
+lib/X11/pyDict/yaba.xpm
+lib/X11/pyDict/z.lib
+share/doc/pyDict/CHANGELOG
+share/doc/pyDict/COPYING
+share/doc/pyDict/README
+@dirrm lib/X11/pyDict
+@dirrm share/doc/pyDict