aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-04-15 18:47:24 +0800
committerijliao <ijliao@FreeBSD.org>2002-04-15 18:47:24 +0800
commit7ad5f1bc69fda5f58dd62dcb41d8b4c1cde260a9 (patch)
tree9c85f1e85f3135db5264c11f056f7d74fea9fd50 /chinese
parentd9708a2ef5a9d763fbaaa38289122a2d420d19c5 (diff)
downloadfreebsd-ports-gnome-7ad5f1bc69fda5f58dd62dcb41d8b4c1cde260a9.tar.gz
freebsd-ports-gnome-7ad5f1bc69fda5f58dd62dcb41d8b4c1cde260a9.tar.zst
freebsd-ports-gnome-7ad5f1bc69fda5f58dd62dcb41d8b4c1cde260a9.zip
upgrade to 0.1.4
PR: 37093 Submitted by: maintainer
Diffstat (limited to 'chinese')
-rw-r--r--chinese/qterm/Makefile8
-rw-r--r--chinese/qterm/distinfo2
-rw-r--r--chinese/qterm/files/patch-Makefile19
-rw-r--r--chinese/qterm/files/patch-configure32
-rw-r--r--chinese/qterm/files/patch-qterm.cpp22
-rw-r--r--chinese/qterm/files/patch-qterm::Makefile.in11
-rw-r--r--chinese/qterm/files/patch-qterm::qtermtelnet.h13
-rw-r--r--chinese/qterm/pkg-plist16
8 files changed, 68 insertions, 55 deletions
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index e793838b2b6d..6437509e51ca 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -6,17 +6,15 @@
#
PORTNAME= qterm
-PORTVERSION= 0.1.3
+PORTVERSION= 0.1.4
CATEGORIES= chinese
-MASTER_SITES= http://qterm.gnuchina.org/qterm-0.1.3/ \
+MASTER_SITES= http://qterm.gnuchina.org/qterm-${PORTVERSION}/ \
ftp://freebsd.sinica.edu.tw/pub/statue/qterm/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= statue@freebsd.sinica.edu.tw
USE_QT_VER= 2
USE_GMAKE= yes
-
-WRKSRC= ${WRKDIR}/qterm-${PORTVERSION}/src
+HAS_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/chinese/qterm/distinfo b/chinese/qterm/distinfo
index a822de506ece..e894bf657e78 100644
--- a/chinese/qterm/distinfo
+++ b/chinese/qterm/distinfo
@@ -1 +1 @@
-MD5 (qterm-0.1.3-1.tar.gz) = 7927d248104b65d0b07a4b5edd5ab5f8
+MD5 (qterm-0.1.4.tar.gz) = 92a415735b932c3248df0b27c4494792
diff --git a/chinese/qterm/files/patch-Makefile b/chinese/qterm/files/patch-Makefile
deleted file mode 100644
index 3ec4ccb77cbb..000000000000
--- a/chinese/qterm/files/patch-Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.orig Wed Sep 5 14:45:55 2001
-+++ Makefile Thu Oct 25 12:11:14 2001
-@@ -11,12 +11,12 @@
- CXX = g++
- CFLAGS = -pipe -Wall -W -O2 -DNO_DEBUG
- CXXFLAGS= -pipe -Wall -W -O2 -DNO_DEBUG
--INCPATH = -I$(QTDIR)/include
-+INCPATH = -I/usr/X11R6/include/qt2
- LINK = g++
- LFLAGS =
--LIBS = $(SUBLIBS) -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt -lXext -lX11 -lm
--MOC = $(QTDIR)/bin/moc
--UIC = $(QTDIR)/bin/uic
-+LIBS = $(SUBLIBS) -L$(QTDIR)/lib -L/usr/X11R6/lib -lqt2 -lXext -lX11 -lm
-+MOC = /usr/X11R6/bin/moc2
-+UIC = /usr/X11R6/bin/uic
-
- TAR = tar -cf
- GZIP = gzip -9f
diff --git a/chinese/qterm/files/patch-configure b/chinese/qterm/files/patch-configure
new file mode 100644
index 000000000000..88f0e3c30125
--- /dev/null
+++ b/chinese/qterm/files/patch-configure
@@ -0,0 +1,32 @@
+--- configure.ori Sat Mar 30 20:59:41 2002
++++ configure Sat Mar 30 21:03:14 2002
+@@ -5564,7 +5564,7 @@
+ if test "x$kde_use_qt_emb" = "xyes"; then
+ qtlib="qte"
+ else
+- qtlib="qt"
++ qtlib="qt2"
+ fi
+
+ LIBQT="-l$qtlib"
+@@ -6003,16 +6003,16 @@
+ IFS=$kde_save_IFS
+
+ for dir in $dirs; do
+- if test -x "$dir/moc"; then
++ if test -x "$dir/moc2"; then
+ if test -n ""
+ then
+- evalstr="$dir/moc 2>&1 "
++ evalstr="$dir/moc2 2>&1 "
+ if eval $evalstr; then
+- kde_cv_path="$dir/moc"
++ kde_cv_path="$dir/moc2"
+ break
+ fi
+ else
+- kde_cv_path="$dir/moc"
++ kde_cv_path="$dir/moc2"
+ break
+ fi
+ fi
diff --git a/chinese/qterm/files/patch-qterm.cpp b/chinese/qterm/files/patch-qterm.cpp
deleted file mode 100644
index de9f77143912..000000000000
--- a/chinese/qterm/files/patch-qterm.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- qterm.cpp.orig Thu Oct 25 22:28:43 2001
-+++ qterm.cpp Tue Feb 19 09:37:37 2002
-@@ -340,8 +340,8 @@
- }
- else if(stat( strGlobal+"/qterm.cfg",&st)== 0)
- {
-- strCmd="/bin/cp"+strGlobal;
-- strCmd+="qterm.cfg ";
-+ strCmd="/bin/cp "+strGlobal;
-+ strCmd+="/qterm.cfg ";
- strCmd+=strMain;
- if( system(strCmd)<0 )
- {
-@@ -382,7 +382,7 @@
- else if(stat( strGlobal+"/pic",&st)== 0)
- {
- strCmd="/bin/cp -fr "+strGlobal;
-- strCmd+="/pic";
-+ strCmd+="/pic ";
- strCmd+=strMain;
- if( system(strCmd)<0 )
- {
diff --git a/chinese/qterm/files/patch-qterm::Makefile.in b/chinese/qterm/files/patch-qterm::Makefile.in
new file mode 100644
index 000000000000..339b0e01f331
--- /dev/null
+++ b/chinese/qterm/files/patch-qterm::Makefile.in
@@ -0,0 +1,11 @@
+--- qterm/Makefile.in.ori Sat Mar 30 21:38:05 2002
++++ qterm/Makefile.in Sat Mar 30 21:38:11 2002
+@@ -142,7 +142,7 @@
+ LIB_KSPELL = @LIB_KSPELL@
+ LIB_KSYCOCA = @LIB_KSYCOCA@
+ LIB_KWRITE = @LIB_KWRITE@
+-LIB_QT = @LIB_QT@
++LIB_QT = -lqt2 @LIB_QT@
+ LIB_SMB = @LIB_SMB@
+ LIB_X11 = @LIB_X11@
+ LIB_XEXT = @LIB_XEXT@
diff --git a/chinese/qterm/files/patch-qterm::qtermtelnet.h b/chinese/qterm/files/patch-qterm::qtermtelnet.h
new file mode 100644
index 000000000000..4e2bd0faa4a4
--- /dev/null
+++ b/chinese/qterm/files/patch-qterm::qtermtelnet.h
@@ -0,0 +1,13 @@
+--- qterm/qtermtelnet.h.ori Sat Mar 30 21:15:46 2002
++++ qterm/qtermtelnet.h Sat Mar 30 21:18:47 2002
+@@ -8,8 +8,9 @@
+ #include <winsock2.h>
+ #else
+ #include <netdb.h>
+- #include <sys/socket.h>
+ #include <sys/types.h>
++ #include <netinet/in.h>
++ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #endif
+
diff --git a/chinese/qterm/pkg-plist b/chinese/qterm/pkg-plist
index 192864dc0655..db57f42db550 100644
--- a/chinese/qterm/pkg-plist
+++ b/chinese/qterm/pkg-plist
@@ -1,12 +1,12 @@
bin/qterm
-lib/qterm/cursor/downArrow.bmp
-lib/qterm/cursor/leftArrow.bmp
-lib/qterm/cursor/m_downArrow.bmp
-lib/qterm/cursor/m_leftArrow.bmp
-lib/qterm/cursor/m_rightArrow.bmp
-lib/qterm/cursor/m_upArrow.bmp
-lib/qterm/cursor/rightArrow.bmp
-lib/qterm/cursor/upArrow.bmp
+lib/qterm/cursor/end.xpm
+lib/qterm/cursor/exit.xpm
+lib/qterm/cursor/home.xpm
+lib/qterm/cursor/mask.xpm
+lib/qterm/cursor/next.xpm
+lib/qterm/cursor/pagedown.xpm
+lib/qterm/cursor/pageup.xpm
+lib/qterm/cursor/prev.xpm
lib/qterm/pic/addr.bmp
lib/qterm/pic/anti.bmp
lib/qterm/pic/beep.bmp