aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-PyGreSQL
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2001-10-16 22:37:37 +0800
committernectar <nectar@FreeBSD.org>2001-10-16 22:37:37 +0800
commitbe18c7bf2ce7da8a74889c9a1d7570a2c9817201 (patch)
treeee9b9c6f5697a6b1fa5fe2976d2f59eb3f62dbad /databases/py-PyGreSQL
parente94fa768bd2f5f8cd6181eabe68d056aeef8a835 (diff)
downloadfreebsd-ports-gnome-be18c7bf2ce7da8a74889c9a1d7570a2c9817201.tar.gz
freebsd-ports-gnome-be18c7bf2ce7da8a74889c9a1d7570a2c9817201.tar.zst
freebsd-ports-gnome-be18c7bf2ce7da8a74889c9a1d7570a2c9817201.zip
Fix import of DateTime module.
Submitted by: olgeni
Diffstat (limited to 'databases/py-PyGreSQL')
-rw-r--r--databases/py-PyGreSQL/Makefile1
-rw-r--r--databases/py-PyGreSQL/files/patch-pgdb.py12
2 files changed, 13 insertions, 0 deletions
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 41c093d77e73..56bb0c33ea81 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PyGreSQL
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
PKGNAMEPREFIX= py-
diff --git a/databases/py-PyGreSQL/files/patch-pgdb.py b/databases/py-PyGreSQL/files/patch-pgdb.py
new file mode 100644
index 000000000000..6f22a42e8474
--- /dev/null
+++ b/databases/py-PyGreSQL/files/patch-pgdb.py
@@ -0,0 +1,12 @@
+--- pgdb.py.orig Thu Oct 11 12:14:35 2001
++++ pgdb.py Thu Oct 11 12:14:42 2001
+@@ -58,7 +58,7 @@
+ import string
+ import exceptions
+ import types
+-import DateTime
++import mx.DateTime
+ import time
+
+ ### module constants
+