aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-06-19 20:41:54 +0800
committerlinimon <linimon@FreeBSD.org>2019-06-19 20:41:54 +0800
commit8e77f57e1d062df874b1bfb7100e354ab678830e (patch)
tree06f30ce895fec5946b2f5df9936d126f00d0162e /databases
parentf7411bcbc67155707134583a7741161394b1dc52 (diff)
downloadfreebsd-ports-gnome-8e77f57e1d062df874b1bfb7100e354ab678830e.tar.gz
freebsd-ports-gnome-8e77f57e1d062df874b1bfb7100e354ab678830e.tar.zst
freebsd-ports-gnome-8e77f57e1d062df874b1bfb7100e354ab678830e.zip
Add compiler:c++11-lang to USES to unbreak build on powerpc64:
ld: final link failed: Bad value While here, pacify portlint by also alpha sorting USES. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'databases')
-rw-r--r--databases/xtrabackup/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/xtrabackup/Makefile b/databases/xtrabackup/Makefile
index 8d673ec8275e..acec3bfff5dc 100644
--- a/databases/xtrabackup/Makefile
+++ b/databases/xtrabackup/Makefile
@@ -18,7 +18,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to compile: cannot combine with previous 'type-name' declaration specifier
BROKEN_armv7= fails to compile: cannot combine with previous 'type-name' declaration specifier
BROKEN_mips64= fails to compile: 'fpsetmask' was not declared in this scope
-BROKEN_powerpc64= fails to link: ld: final link failed: Bad value
# quilt is required by build.sh
BUILD_DEPENDS= bash:shells/bash \
@@ -30,7 +29,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
RUN_DEPENDS= qpress:archivers/qpress
# autotool is in use for 5.1 builds
-USES= alias autoreconf:build bison cpe gettext cmake:noninja libtool perl5 shebangfix
+USES= alias autoreconf:build bison cmake:noninja compiler:c++11-lang \
+ cpe gettext libtool perl5 shebangfix
CPE_VENDOR= percona
SHEBANG_FILES= storage/innobase/xtrabackup/xbcloud_osenv.sh
CMAKE_ARGS= -DWITH_BOOST=${WRKDIR}/boost_1_59_0