aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-02-07 10:44:21 +0800
committerseanc <seanc@FreeBSD.org>2003-02-07 10:44:21 +0800
commit029b18cf87aedbf71e33f8d866f6df8c14ff7289 (patch)
tree2315898546b50fdde5fb0c2b3b87a246f37d3136 /editors
parent1f6ee4fb3acab07e5bf5542a77600b7f2b044939 (diff)
downloadfreebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.tar.gz
freebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.tar.zst
freebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.zip
Correct ports that were abusing the FORBIDDEN variable and replace with
either IGNORE or BROKEN. Since there seems to be some confusion, for the record: BROKEN is reserved for ports that don't work. This will prevent users from installing the port, but please note that ports marked as BROKEN will still be built by bento IGNORE is reserved for ports that should not be built for one reason or another (including bento). Users and bento will not build ports marked as IGNORE. FORBIDDEN is reserved for security breakages only!!! Only mark a port as FORBIDDEN if there is a security issue with the port at the time. Reviewed by: kris (portmgr)
Diffstat (limited to 'editors')
-rw-r--r--editors/apel-xemacs21-mule/Makefile2
-rw-r--r--editors/jedit/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/editors/apel-xemacs21-mule/Makefile b/editors/apel-xemacs21-mule/Makefile
index 81aa06ffd19d..fed9a179de42 100644
--- a/editors/apel-xemacs21-mule/Makefile
+++ b/editors/apel-xemacs21-mule/Makefile
@@ -38,7 +38,7 @@ XEMACS_PKG_CONTENTS= pkginfo/${MANIFEST} lisp/${XEMACS_PKGNAME}
APELDOCDIR= ${EMACS_PACKAGESDIR}/lisp/${XEMACS_PKGNAME}
.if defined(PARALLEL_PACKAGE_BUILD)
-FORBIDDEN= hang
+IGNORE= hang
.endif
xemacs-package: install
diff --git a/editors/jedit/Makefile b/editors/jedit/Makefile
index 8d1420379873..2b75adb4702d 100644
--- a/editors/jedit/Makefile
+++ b/editors/jedit/Makefile
@@ -36,7 +36,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/jedit.sh ${PREFIX}/bin/jedit
.if defined(PARALLEL_PACKAGE_BUILD)
-FORBIDDEN= hang
+IGNORE= hang
.endif
.include <bsd.port.mk>