aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-06-22 05:52:07 +0800
committermi <mi@FreeBSD.org>2002-06-22 05:52:07 +0800
commit2a19f01cea4a6667190fa93db8d32321dd85f051 (patch)
tree8aba76cf37906a52b6758843696d4317266acbc7 /finance
parent2c3edbd402b993f372b2d2d1d9964e33d71d4900 (diff)
downloadfreebsd-ports-gnome-2a19f01cea4a6667190fa93db8d32321dd85f051.tar.gz
freebsd-ports-gnome-2a19f01cea4a6667190fa93db8d32321dd85f051.tar.zst
freebsd-ports-gnome-2a19f01cea4a6667190fa93db8d32321dd85f051.zip
My first PERL -> REINPLACE_CMD conversion. Make sure not to leave anything
behind by explicitly giving "" to -i -- why is that not a default, I wonder.
Diffstat (limited to 'finance')
-rw-r--r--finance/libstocks/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/finance/libstocks/Makefile b/finance/libstocks/Makefile
index 22353dc3b789..c44d2057547f 100644
--- a/finance/libstocks/Makefile
+++ b/finance/libstocks/Makefile
@@ -13,11 +13,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mi@aldan.algebra.com
-#GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
post-patch:
- ${PERL} -pi -e 's/malloc.h/stdlib.h/; s/__UNIX__/__unix__/' \
- ${WRKSRC}/lib/*.c
+ ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
+ -e 's/__UNIX__/__unix__/' \
+ $$(${GREP} --mmap -El '<malloc.h>|__UNIX__' \
+ ${WRKSRC}/lib/*.c); \
+
do-build do-install:
.for d in lib client