aboutsummaryrefslogtreecommitdiffstats
path: root/games/xemeraldia/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-03-25 12:30:54 +0800
committerasami <asami@FreeBSD.org>1995-03-25 12:30:54 +0800
commitbb390c5ea9d7d6414be1c6158f749f7689ba0db7 (patch)
tree2139c7ddc49e73e496e8e5a9567fd1071237ae76 /games/xemeraldia/Makefile
parentd5509b86aeb7a4e9cbad6cde47260b3468711596 (diff)
downloadfreebsd-ports-gnome-bb390c5ea9d7d6414be1c6158f749f7689ba0db7.tar.gz
freebsd-ports-gnome-bb390c5ea9d7d6414be1c6158f749f7689ba0db7.tar.zst
freebsd-ports-gnome-bb390c5ea9d7d6414be1c6158f749f7689ba0db7.zip
Don't uudecode if the .tar.gz file is already there.
Pointed-out by: Anthony Chan <yeehang@netcom.com>
Diffstat (limited to 'games/xemeraldia/Makefile')
-rw-r--r--games/xemeraldia/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/xemeraldia/Makefile b/games/xemeraldia/Makefile
index 4f6ac5ec7afe..fbe18342ae5e 100644
--- a/games/xemeraldia/Makefile
+++ b/games/xemeraldia/Makefile
@@ -19,7 +19,10 @@ extract: fetch ${EXTRACT_COOKIE}
${EXTRACT_COOKIE}:
@${MAKE} ${.MAKEFLAGS} checksum pre-extract
@echo "===> Extracting for ${DISTNAME}"
- @(cd ${DISTDIR}; zcat ${DISTFILES} | uudecode)
+ @(cd ${DISTDIR}; \
+ if [ ! -f ${DISTNAME}.tar.gz ]; then \
+ zcat ${DISTFILES} | uudecode; \
+ fi)
@rm -rf ${WRKDIR}
@mkdir -p ${WRKDIR}
@(cd ${WRKDIR}; tar -xzf \