aboutsummaryrefslogtreecommitdiffstats
path: root/games/xemeraldia/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-03-24 13:27:13 +0800
committerasami <asami@FreeBSD.org>1995-03-24 13:27:13 +0800
commite11c38a60b352e1a51582668804b990ecfe2a90e (patch)
tree21a44b583786dcc58a759d4413a238e004601822 /games/xemeraldia/Makefile
parent5af64f77b1491f467ab7cc0321059bc94e4d7c85 (diff)
downloadfreebsd-ports-gnome-e11c38a60b352e1a51582668804b990ecfe2a90e.tar.gz
freebsd-ports-gnome-e11c38a60b352e1a51582668804b990ecfe2a90e.tar.zst
freebsd-ports-gnome-e11c38a60b352e1a51582668804b990ecfe2a90e.zip
Version 0.2 of xemeraldia. Drop blocks and break them.
Diffstat (limited to 'games/xemeraldia/Makefile')
-rw-r--r--games/xemeraldia/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/xemeraldia/Makefile b/games/xemeraldia/Makefile
new file mode 100644
index 000000000000..e3ab99514293
--- /dev/null
+++ b/games/xemeraldia/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xemeraldia
+# Version required: 0.2
+# Date created: 22 Mar 1995
+# Whom: swallace
+#
+# $Id: Makefile,v 1.1.1.1 1995/01/03 08:46:26 swallace Exp $
+#
+
+DISTNAME= xemeraldia-0.2
+DISTFILES= 250.gz
+MASTER_SITES= ftp://ftp.kuis.kyoto-u.ac.jp/News.Archives/fj.sources/1995/
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+EXTRACT_COOKIE?= ${.CURDIR}/work/.extract_done
+
+extract: fetch ${EXTRACT_COOKIE}
+
+${EXTRACT_COOKIE}:
+ @${MAKE} ${.MAKEFLAGS} checksum pre-extract
+ @echo "===> Extracting for ${DISTNAME}"
+ @(cd ${DISTDIR}; zcat ${DISTFILES} | uudecode)
+ @rm -rf ${WRKDIR}
+ @mkdir -p ${WRKDIR}
+ @(cd ${WRKDIR}; ${EXTRACT_CMD} ${EXTRACT_ARGS} \
+ ${DISTDIR}/${DISTNAME}.tar.gz)
+ @${TOUCH} ${TOUCH_FLAGS} ${EXTRACT_COOKIE}
+
+
+pre-install:
+ touch ${PREFIX}/lib/X11/.xemeraldia.scores
+ chmod 666 ${PREFIX}/lib/X11/.xemeraldia.scores
+
+.include <bsd.port.mk>