aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-12-13 16:47:43 +0800
committerasami <asami@FreeBSD.org>1998-12-13 16:47:43 +0800
commit2d29ba1fd24b51ac250809a074ee2fe8f3fdc076 (patch)
tree76cffede53406193faf8b87e9e0e20f7df3027b9 /games
parent6526ee159b54cf4a3a767a38b1b295cf0afb5491 (diff)
downloadfreebsd-ports-gnome-2d29ba1fd24b51ac250809a074ee2fe8f3fdc076.tar.gz
freebsd-ports-gnome-2d29ba1fd24b51ac250809a074ee2fe8f3fdc076.tar.zst
freebsd-ports-gnome-2d29ba1fd24b51ac250809a074ee2fe8f3fdc076.zip
Don't write stuff to places other than ${WRKDIR}.
Diffstat (limited to 'games')
-rw-r--r--games/doom/Makefile11
-rw-r--r--games/linuxdoom/Makefile11
2 files changed, 10 insertions, 12 deletions
diff --git a/games/doom/Makefile b/games/doom/Makefile
index aa1111a84708..83b711667532 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -3,7 +3,7 @@
# Date created: Mon Dec 9 09:42:37 CST 1996
# Whom: erich@rrnet.com
#
-# $Id: Makefile,v 1.4 1997/07/13 18:49:14 max Exp $
+# $Id: Makefile,v 1.5 1997/11/29 00:49:08 jseger Exp $
#
DISTNAME= doom-1.8
@@ -17,19 +17,18 @@ MAINTAINER= erich@FreeBSD.org
BUILD_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_lib
RUN_DEPENDS= /compat/linux/lib/libc.so.5:${PORTSDIR}/emulators/linux_lib
+USE_XLIB= yes
NO_WRKSUBDIR= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
post-patch:
@(cd ${WRKSRC}/joystick4doom; make clean)
@(cd ${WRKSRC}/musserver; make clean)
pre-install:
- @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGDIR}/INSTALL
+ @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGINSTALL}
post-install:
- @${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
-
-pre-clean:
- @rm -f ${PKGDIR}/INSTALL
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/games/linuxdoom/Makefile b/games/linuxdoom/Makefile
index aa1111a84708..83b711667532 100644
--- a/games/linuxdoom/Makefile
+++ b/games/linuxdoom/Makefile
@@ -3,7 +3,7 @@
# Date created: Mon Dec 9 09:42:37 CST 1996
# Whom: erich@rrnet.com
#
-# $Id: Makefile,v 1.4 1997/07/13 18:49:14 max Exp $
+# $Id: Makefile,v 1.5 1997/11/29 00:49:08 jseger Exp $
#
DISTNAME= doom-1.8
@@ -17,19 +17,18 @@ MAINTAINER= erich@FreeBSD.org
BUILD_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_lib
RUN_DEPENDS= /compat/linux/lib/libc.so.5:${PORTSDIR}/emulators/linux_lib
+USE_XLIB= yes
NO_WRKSUBDIR= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
post-patch:
@(cd ${WRKSRC}/joystick4doom; make clean)
@(cd ${WRKSRC}/musserver; make clean)
pre-install:
- @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGDIR}/INSTALL
+ @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGINSTALL}
post-install:
- @${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
-
-pre-clean:
- @rm -f ${PKGDIR}/INSTALL
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>