aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/latex2html/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-03 12:04:20 +0800
committerSteve Price <steve@FreeBSD.org>1999-05-03 12:04:20 +0800
commit27119f9454bcf6ea32d2fd09b9d20882c1a0950f (patch)
tree74923032cebc34abea7dc4b90fc78de13297d523 /japanese/latex2html/Makefile
parented2845b7a3856e2ed4432cf45919eb736c80e703 (diff)
downloadfreebsd-ports-gnome-27119f9454bcf6ea32d2fd09b9d20882c1a0950f.tar.gz
freebsd-ports-gnome-27119f9454bcf6ea32d2fd09b9d20882c1a0950f.tar.zst
freebsd-ports-gnome-27119f9454bcf6ea32d2fd09b9d20882c1a0950f.zip
Initial import of ja-latex2html version 98.1j2.1.
A Japanese version of the latex to html converter. PR: 11337 Submitted by: Sugimoto Sadahiro <ixtl@utmc.or.jp>
Diffstat (limited to 'japanese/latex2html/Makefile')
-rw-r--r--japanese/latex2html/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/japanese/latex2html/Makefile b/japanese/latex2html/Makefile
new file mode 100644
index 000000000000..2dccbb24eadb
--- /dev/null
+++ b/japanese/latex2html/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: ja-latex2html
+# Version required: 98.1jpatch-2.1
+# Date created: 3 Apr 1999
+# Whom: Sugimoto Sadahiro <ixtl@utmc.or.jp>
+#
+# $Id$
+#
+# Default image format is GIF.
+# If you prefer PNG to GIF, define USE_PNG (`make -DUSE_PNG`).
+
+DISTNAME= latex2html-98.1p1
+PKGNAME= ja-latex2html-98.1j2.1
+CATEGORIES= japanese textproc
+MASTER_SITES= http://www-dsed.llnl.gov/files/programs/unix/latex2html/sources/ \
+ ftp://ftp.mpn.com/pub/nikos/latex2html-mirror/sources/ \
+ http://www.topstudio.co.jp/~kmuto/software/latex2html/patch/98-1/
+DISTFILES= latex2html-98.1p1.tar.gz latex2html-98.1jpatch-2.1.tar.gz
+
+MAINTAINER= ixtl@utmc.or.jp
+
+RUN_DEPENDS= ${PREFIX}/bin/latex:${PORTSDIR}/print/latex \
+ ${PREFIX}/bin/dvips:${PORTSDIR}/print/dvips \
+ ${PREFIX}/bin/gs:${PORTSDIR}/print/ghostscript5 \
+ ${X11BASE}/bin/anytopnm:${PORTSDIR}/graphics/netpbm
+
+.ifdef USE_PNG
+RUN_DEPENDS += ${X11BASE}/bin/pnmtopng:${PORTSDIR}/graphics/pnmtopng
+.endif
+
+WRKSRC= ${WRKDIR}/latex2html
+USE_PERL5= yes
+NO_BUILD= yes
+
+L2HDIR= ${PREFIX}/share/jlatex2html
+
+post-patch:
+ @${PATCH} ${PATCH_ARGS} -o ${WRKDIR}/jlatex2html < ${WRKDIR}/jlatex2html.dif
+ @${PATCH} ${PATCH_ARGS} -o ${WRKDIR}/jlatex2html.config \
+ < ${WRKDIR}/jlatex2html.config.dif
+ @for file in latex2html/configure-pstoimg latex2html/texexpand \
+ latex2html/pstoimg latex2html/pstoimg_nopipes \
+ jlatex2html.config jlatex2html; do \
+ ${PERL} -pi.org -e \
+ "s|LATEX2HTMLDIR\s*=.*;|LATEX2HTMLDIR='${L2HDIR}';|; s|^use lib.*;|use lib '${L2HDIR}';|;" \
+ ${WRKDIR}/$$file; \
+ done
+.ifdef USE_PNG
+ @${PERL} -pi -e "s|IMAGE_TYPE=.*;|IMAGE_TYPE='png';|" \
+ ${WRKDIR}/jlatex2html.config
+.endif
+
+do-install:
+ @${MKDIR} ${L2HDIR}
+ @${INSTALL_DATA} ${FILESDIR}/local.pm ${L2HDIR}
+ @ for dir in makeseg IndicTeX-HTML cweb2html docs example icons.gif icons.png styles tests versions; do \
+ ${CP} -R ${WRKSRC}/$$dir ${L2HDIR}; \
+ done
+ @ for prog in Override.pm configure-pstoimg install-test makemap pstoimg\
+ pstoimg_nopipes texexpand; do \
+ ${INSTALL_SCRIPT} ${WRKSRC}/$$prog ${L2HDIR}; \
+ done
+ @ for file in FAQ MANIFEST README README.dvips dot.latex2html-init; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$file ${L2HDIR}; \
+ done
+ @${MKDIR} ${PREFIX}/share/texmf/tex/latex/jlatex2html
+ @${INSTALL_DATA} ${WRKSRC}/texinputs/* ${PREFIX}/share/texmf/tex/latex/jlatex2html
+ @${INSTALL_SCRIPT} ${WRKDIR}/jlatex2html ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/jlatex2html ${L2HDIR}
+ @${INSTALL_DATA} ${WRKDIR}/jlatex2html.config ${L2HDIR}
+ @ for dir in styles versions; do \
+ ${MKDIR} ${L2HDIR}/$$dir; \
+ ${INSTALL_DATA} ${WRKDIR}/$$dir/* ${L2HDIR}/$$dir; \
+ done
+
+.include <bsd.port.mk>