aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/latex2html/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2000-07-03 21:28:05 +0800
committerSADA Kenji <sada@FreeBSD.org>2000-07-03 21:28:05 +0800
commit526d59b69324e1f6a1d4d0bc4598d87c5b37c39d (patch)
tree751f24810864ac4b55608c7622f0f357b8a626fd /japanese/latex2html/Makefile
parent1a63ceebf55e7cd9ae07a4233432dac8180c2921 (diff)
downloadfreebsd-ports-gnome-526d59b69324e1f6a1d4d0bc4598d87c5b37c39d.tar.gz
freebsd-ports-gnome-526d59b69324e1f6a1d4d0bc4598d87c5b37c39d.tar.zst
freebsd-ports-gnome-526d59b69324e1f6a1d4d0bc4598d87c5b37c39d.zip
1. Justify files/* .
2. To be used 'install-test', the original install script which is included in the archive. PR: ports/19173 Submitted by: Maintainer
Diffstat (limited to 'japanese/latex2html/Makefile')
-rw-r--r--japanese/latex2html/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/japanese/latex2html/Makefile b/japanese/latex2html/Makefile
index 2991e47fd004..dcab4adcdd66 100644
--- a/japanese/latex2html/Makefile
+++ b/japanese/latex2html/Makefile
@@ -38,28 +38,14 @@ NO_BUILD= yes
L2HDIR= ${PREFIX}/share/latex2html
post-patch:
-.for f in configure-pstoimg latex2html latex2html.config \
- ps2img-n pstoimg pstoimg_nopipes
- ${PERL} -e "s:\\\$$ENV{'L2HMODULE'}/user:${L2HDIR}:" \
- -pi ${WRKSRC}/$f
-.endfor
.for f in configure-pstoimg install-test latex2html makemap \
ps2img-n pstoimg pstoimg_nopipes texexpand
${PERL} -e "s:^\#!/usr/local/bin/perl:\#!${PERL}:" \
-pi ${WRKSRC}/$f
.endfor
- ${PERL} -e "s:^use lib \"/usr/local/share/latex2html\":use lib \'${L2HDIR}\':" \
- ${PERL} -e "s:/usr/local/share/latex2html:${L2HDIR}:" \
- -pi ${WRKSRC}/texexpand
-.ifdef WITH_GIF
- ${PERL} -pi -e "s|IMAGE_TYPE=.*;|IMAGE_TYPE='gif';|" \
- ${WRKSRC}/latex2html.config
-.endif
do-install:
${MKDIR} ${L2HDIR}
- ${INSTALL_DATA} ${FILESDIR}/local.pm ${FILESDIR}/DBM.tst.db \
- ${FILESDIR}/TEST2.TMP ${L2HDIR}
.for dir in IndicTeX-HTML XyMTeX-HTML cweb2html docs/changebar \
docs/hthtml docs/psfiles docs example foilhtml icon-dos icons.gif \
icons.png makeseg styles tests texinputs versions
@@ -75,6 +61,11 @@ do-install:
.endfor
${MKDIR} ${PREFIX}/share/texmf/tex/latex/latex2html
${INSTALL_DATA} ${WRKSRC}/texinputs/* ${PREFIX}/share/texmf/tex/latex/latex2html
- ${INSTALL_SCRIPT} ${WRKSRC}/latex2html ${PREFIX}/bin
+.ifdef WITH_GIF
+ cd ${L2HDIR}; ${CAT} ${FILESDIR}/answer-gif | ${PERL} install-test
+.else
+ cd ${L2HDIR}; ${CAT} ${FILESDIR}/answer-png | ${PERL} install-test
+.endif
+ ${INSTALL_SCRIPT} ${L2HDIR}/latex2html ${PREFIX}/bin
.include <bsd.port.mk>