aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mimekit
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-04-30 13:13:45 +0800
committerasami <asami@FreeBSD.org>1996-04-30 13:13:45 +0800
commit0af4e5c82e298c998b19ee22bf4f872e6e58bef2 (patch)
tree8de9b0e289510f539511df1be9f4ce823978ecc3 /japanese/mimekit
parent79527d85f4463c5857a283d3ab8cfc96699adec4 (diff)
downloadfreebsd-ports-gnome-0af4e5c82e298c998b19ee22bf4f872e6e58bef2.tar.gz
freebsd-ports-gnome-0af4e5c82e298c998b19ee22bf4f872e6e58bef2.tar.zst
freebsd-ports-gnome-0af4e5c82e298c998b19ee22bf4f872e6e58bef2.zip
A little library with functions to encode/decode MIME headers.
Diffstat (limited to 'japanese/mimekit')
-rw-r--r--japanese/mimekit/Makefile19
-rw-r--r--japanese/mimekit/distinfo1
-rw-r--r--japanese/mimekit/files/patch-aa33
-rw-r--r--japanese/mimekit/pkg-comment1
-rw-r--r--japanese/mimekit/pkg-descr6
-rw-r--r--japanese/mimekit/pkg-plist3
6 files changed, 63 insertions, 0 deletions
diff --git a/japanese/mimekit/Makefile b/japanese/mimekit/Makefile
new file mode 100644
index 000000000000..0a66bdd18e95
--- /dev/null
+++ b/japanese/mimekit/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: mimekit
+# Version required: 1.1
+# Date created: 9 April 1996
+# Whom: Masafumi NAKANE <max@sfc.wide.ad.jp>
+#
+# $Id: porting.sgml,v 1.16 1996/03/21 14:15:01 asami Exp $
+#
+
+DISTNAME= mimekit1.1
+PKGNAME= mimekit-1.1
+CATEGORIES+= japanese mail
+MASTER_SITES= ftp://etlport.etl.go.jp/pub/ccipr/DeleGate/ \
+ ftp://ftp.iij.ad.jp/pub/mail/mime/
+
+MAINTAINER= max@sfc.wide.ad.jp
+
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.mk>
diff --git a/japanese/mimekit/distinfo b/japanese/mimekit/distinfo
new file mode 100644
index 000000000000..3b66da48a1fc
--- /dev/null
+++ b/japanese/mimekit/distinfo
@@ -0,0 +1 @@
+MD5 (mimekit1.1.tar.gz) = a0e945e65f9d2108c7e86d212dafc2bf
diff --git a/japanese/mimekit/files/patch-aa b/japanese/mimekit/files/patch-aa
new file mode 100644
index 000000000000..4173fedb8244
--- /dev/null
+++ b/japanese/mimekit/files/patch-aa
@@ -0,0 +1,33 @@
+--- ./Makefile.org Fri Dec 1 23:55:07 1995
++++ ./Makefile Fri Apr 26 01:15:07 1996
+@@ -12,7 +12,7 @@
+ MMDIR = ../../../src
+ MMSDIR = ../
+ DGDIR = ../src
+-INSTDIR = /usr/local/lib
++INSTDIR = ${PREFIX}/lib
+
+ LOCALFILES = README \
+ README.jp \
+@@ -52,7 +52,7 @@
+ ALL = toMime fromMime enMime deMime test.out bench
+
+ CC = cc
+-CFLAGS = -O
++CFLAGS += -O
+ RM = rm -f
+ RANLIB = `./mkranlib`
+ TAR = tar
+@@ -98,9 +98,9 @@
+ enMime deMime bench.o test.out
+
+ install: fromMime toMime $(LIBMKIT)
+- install -o bin -g bin -m 755 fromMime $(INSTDIR)
+- install -o bin -g bin -m 755 toMime $(INSTDIR)
+- install -o root -g staff -m 644 $(LIBMKIT) $(INSTDIR)
++ install -cs -o bin -g bin -m 755 fromMime $(INSTDIR)
++ install -cs -o bin -g bin -m 755 toMime $(INSTDIR)
++ install -o bin -g bin -m 644 $(LIBMKIT) $(INSTDIR)
+ $(RANLIB) $(INSTDIR)/$(LIBMKIT)
+
+ config.h:; ln -s $(MMDIR)/config.h .
diff --git a/japanese/mimekit/pkg-comment b/japanese/mimekit/pkg-comment
new file mode 100644
index 000000000000..1a52373af5fd
--- /dev/null
+++ b/japanese/mimekit/pkg-comment
@@ -0,0 +1 @@
+Library to handle messages with MIME-encoded headers.
diff --git a/japanese/mimekit/pkg-descr b/japanese/mimekit/pkg-descr
new file mode 100644
index 000000000000..9c1636b780e0
--- /dev/null
+++ b/japanese/mimekit/pkg-descr
@@ -0,0 +1,6 @@
+This library contains functions to encode/decode MIME header.
+
+It provides functions ``MIME_strHeaderEncode'' and
+``MIME_strHeaderEncode''.
+
+- Masafumi
diff --git a/japanese/mimekit/pkg-plist b/japanese/mimekit/pkg-plist
new file mode 100644
index 000000000000..c3271b803e1f
--- /dev/null
+++ b/japanese/mimekit/pkg-plist
@@ -0,0 +1,3 @@
+lib/fromMime
+lib/toMime
+lib/libmimekit.a